Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

Updating Path Script


#1

Hi All,

Using Portfolio Server 11 on a 2012 Mac Mini running 10.8.3

I need to mass update paths for certain catalogs. I’ve read there is a script around. Also, each catalog has roughly 4,000 images.

Long story short/simplified - Folder A was originally named ‘Folder-A’. Six months worth of images were tagged. Folder-A was then renamed to ‘Folder-B’ (accidentally). Six months of additional Images were tagged.

When you reveal the original image, the images linked to ‘Folder-A’ are broken because they’re pointing to the wrong folder, since ‘Folder-B’ is now the ‘master’ folder. Everything is still tagged, however.

Renaming the ‘master’ folder (renaming ‘Folder-B’ back to ‘Folder-A’) causes the other 6 months worth of images to have broken paths as well.

Is there an easy way to update file paths without the script? I know you can manually update file paths but I have a to do that to a ton of images. If not, where can I get this script?

Note - I tried the option of dragging the folders and holding option and that did not update the paths, it asked me which to keep and there was no ‘apply new path for all’ option. In other words, I would have to keep updating each path one by one.

Thanks!


#2

Anyone?


#3

Please contact the support team and they will provide you with a script to edit the paths.

extensis.com/support/contac … l-support/


#4

They don’t provide that script anymore. I asked for it and got the reply that I had to do it via the alt-drag to client way. Fantastic, as the client just crashes on every 100th pic it gets thrown. Who came up with the GENIUS idea of keeping the path stored statically? This software gets more and more useless…


#5

That sounds like some sort of catalog corruption. Have you tried recovering the catalog? I’ve done path updates using the alt/option drag & drop method on catalogs with over 20,000 records without it getting interrupted. So if it’s stopping repeatedly at the same point of just 100 or so files, that suggests there’s an issue with either a particular record or the catalog itself.


#6

Catalog has been recovered a few times as an option. I’m now onto trying to see if the same photos generate the error every time - and possibly why.