Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

Suitcase not working in Adobe Illustrator CC 2015 R2


#1

I upgraded yesterday to AI CC 2015 Release 2 (19.2.0) and now Suitcase Extension shows no fonts in Illustrator. Has anyone else seen this?

It isn’t working in InDesign 2015.2 Release (11.2.0.100) either.


#2

I’ve got the same problem, the plugins aren’t working anymore although auto-activation does still work.

Will there be an update for this?


#3

Me too. This is so frustrating. It was only a few weeks ago that we finally got working plugins, and now they’re broken again?!?


#4

All,

Extensis is aware of the issue where our font panels are not working with the Adobe CC2015.2 release. However the auto-activation plugins still should function as expected. The Suitcase Team is investigating the problem and will provide a fix as soon as possible.
In the mean time, we recommend activating your fonts from within the Suitcase application as a temporary workaround.

Let us know if you have any additional questions or concerns.

Cheers,
Chris


#5

[quote=“CMeyer”]All,

Extensis is aware of the issue where our font panels are not working with the Adobe CC2015.2 release. However the auto-activation plugins still should function as expected. The Suitcase Team is investigating the problem and will provide a fix as soon as possible.
In the mean time, we recommend activating your fonts from within the Suitcase application as a temporary workaround.

Let us know if you have any additional questions or concerns.

Cheers,
Chris[/quote]

Awesome! Thanks Chris.


#6

[quote=“CMeyer”]All,

Extensis is aware of the issue where our font panels are not working with the Adobe CC2015.2 release. However the auto-activation plugins still should function as expected. The Suitcase Team is investigating the problem and will provide a fix as soon as possible.
In the mean time, we recommend activating your fonts from within the Suitcase application as a temporary workaround.

Let us know if you have any additional questions or concerns.

Cheers,
Chris[/quote]

Chris,
Happening in Photoshop too, but I’m guessing Extensis is aware of that.

For us lay people who this affects each time Adobe release a major update, could you explain why this happens every time?

I’ve lost count of how many times after each Adobe update, this happens. Seems to be the same cycle of:

(1) Adobe release a new update to CC
(2) All plugins for Photoshop / Illustrator/ Indesign develop faults ranging from not showing at all, to minor niggles with particular fonts
(3) Users visit the forums to complain yet again
(4) Someone from Extensis says they’re aware of it and they’re fixing it but have no timescales and cant for reason abc prepare for this until it happens
(5) Weeks later, loyal paying customers are still waiting but told it will be fixed “very soon”, in the meantime it causes major disruption.
(6) Updates start to trickle out to resolve one or two issues after yet more complaints and requests for timescales for fixes
(7) Finally, the version that you use (usually Windows) gets released and all is well for a month or two until Adobe bring out another update.

Cycle 1-7 continues to happen, but in the mean time:

(8) Eventually the version you paid for is replaced for a new version which you only got 50% of actual usage with because of the broken down time, so you stick with the old version as you cant justify paying for the new one yet.
(9) Extensis stop providing updates to your “old version” (as its apparently too old to justify updating) inevitably around the same time yet another plugin fails, which may only be a year or so “old” so you’re forced into upgrading to the new one in the hope the plugin actually works again. Obviously it inevitably hasnt been fixed to work with the new CC update, so you paid for something you have to wait weeks again to be fixed.

“Not professional and a major screw up to our business”, is the politest criticism I can make on this forum, Chris. It may be a mix of perception and facts, but this shouldnt be happening each time. I’ve lost weeks of time to this problem over the years. Thats lots of money the business shouldnt keep having to lose. There must be more that can be done to prepare for this in advance.

This could be the last time we incorporate Extensis software into our workflow if it keeps causing more disruption than it resolves. Such a shame, as its great when working properly.

So is the above cycle going to happen yet again?


#7

Two weeks now. Any progress?


#8

All,
We are scrambling to include a handful of OS compatibility and plugin stability bugs in our next dot release so I wanted to give you a quick update:
I will have a fix for you all to test by the end of this week. It will not be our final release but hopefully should restore the panels as you expect until we officially release it later in January.

Our goal is to include a few other fixes in the release but in the meanwhile I can provide a solid prerelease version with the panels fix this week.

@davezarr: I appreciate your feedback and hear your frustration. I promise to provide a more comprehensive reply to your concerns soon but need to ensure I squeeze every ounce of development work out of my team before they head out for the holiday break. So I will post a response back here in a few days.

I will provide the download links as soon as they are ready. Stay tuned…

Cheers,
Chris


#9

Thanks Chris!


#10

Greetings,

We have a pre-release build of our next Suitcase Fusion update available that is expected to resolve this issue. Feel free to test this out and report any feedback here or in a private message. This is a pre-release that has not been completely tested but should be suitable for normal use. If you experience any additional troubles with this release please let me know.

Suitcase Fusion 6 (v 17.2.2): bin.extensis.com/SuitcaseFusionWinBeta121715.zip

I will be actively monitoring these forums for any feedback.

Thanks!
Ryan C Brown
Extensis Font Management QA


#11

[quote=“rbrown”]Greetings,

We have a pre-release build of our next Suitcase Fusion update available that is expected to resolve this issue. Feel free to test this out and report any feedback here or in a private message. This is a pre-release that has not been completely tested but should be suitable for normal use. If you experience any additional troubles with this release please let me know.

Suitcase Fusion 6 (v 17.2.2): bin.extensis.com/SuitcaseFusionWinBeta121715.zip

I will be actively monitoring these forums for any feedback.

Thanks!
Ryan C Brown
Extensis Font Management QA[/quote]

Thanks Ryan!

Going to install and test this out now, will report back if I run into any problems with it.


#12

The new version seems to have fixed the problems. It is working in AI, ID, and PS for me now.

Thanks.


#13

[quote=“CMeyer”]All,
We are scrambling to include a handful of OS compatibility and plugin stability bugs in our next dot release so I wanted to give you a quick update:
I will have a fix for you all to test by the end of this week. It will not be our final release but hopefully should restore the panels as you expect until we officially release it later in January.

Our goal is to include a few other fixes in the release but in the meanwhile I can provide a solid prerelease version with the panels fix this week.

@davezarr: I appreciate your feedback and hear your frustration. I promise to provide a more comprehensive reply to your concerns soon but need to ensure I squeeze every ounce of development work out of my team before they head out for the holiday break. So I will post a response back here in a few days.

I will provide the download links as soon as they are ready. Stay tuned…

Cheers,
Chris[/quote]

Thanks Chris.
Thanks Ryan.


#14

[quote=“davezarr”]

[quote=“CMeyer”]All,
We are scrambling to include a handful of OS compatibility and plugin stability bugs in our next dot release so I wanted to give you a quick update:
I will have a fix for you all to test by the end of this week. It will not be our final release but hopefully should restore the panels as you expect until we officially release it later in January.

Our goal is to include a few other fixes in the release but in the meanwhile I can provide a solid prerelease version with the panels fix this week.

@davezarr: I appreciate your feedback and hear your frustration. I promise to provide a more comprehensive reply to your concerns soon but need to ensure I squeeze every ounce of development work out of my team before they head out for the holiday break. So I will post a response back here in a few days.

I will provide the download links as soon as they are ready. Stay tuned…

Cheers,
Chris[/quote]

Thanks Chris.
Thanks Ryan.[/quote]

Hi Chris/ Ryan,

Happy New Year.

I presume the team are returning from their holidays now. Any update as to when we can see the full release version with the fixed panel issues please? I’m reluctant to install / test the pre release if the final release is around the corner.

Thanks. Dave.


#15

Any word on when we might expect the Mac OS version of this fix? Thx!


#16

The “fix” never properly worked in Photoshop for me, and now it’s not working in Illustrator either, although it did until earlier today.


#17

Problem here too after downloading the recent beta version “fix” on Win 10 x64 PC. Latest CC2015.

I installed it, plugin panel worked OK until today when I re-started my computer and booted up Photoshop as normal.

I’m getting the error “The Extensis extension could not be loaded because it was not properly signed”.

Tried switching on and off various setting in PS: file> Automate> Extensis, and turning Google fonts on and off in SF6 in a vain attempt to resolve it. Nothing but the error still.

Back to square one and no plugin again :angry:

Whens this going to get finally fixed (or until the next update to CC when it all starts again!)?

edit: After 2 hours of installing/ uninstalling software to try and fix this, I finally found a blog article from Extensis at blog.extensis.com/font-managemen … oducts.php

Quote: “Today, the security certificate used to verify the validity of our application expired. If you attempt to load Extensis Font Panel in Adobe Photoshop, InDesign or Illustrator Creative Cloud 2014 or 2015 you will receive the error “The Extensis extension could not be loaded because it was not properly signed.””
… “We expect to release patches to fix this issue within the next few days.”

[bangs head against wall] Sounds like a dropped ball from Extensis. :angry:

I wish when something like this happens, that an email would be sent out to registerred users of a product instead of relying on users of the software to subscribe or jump back and forth to read a blog announcement. I for one dont have time/ interest/ desire or even thought about checking blog announcements in case this problem was widespread.

I’ve only just got the panel working with the beta fix, then goes again and waste 2hrs to find out its not my systems fault yet again!

I do hope Extensis are going to reward us VERY PATIENT customers for all this messing about we keep going through, as an apology. I only get to use the plugins about 50% of the time I should because of all the problems with them. Do we get a 50%+ discount code above and beyond the usual upgrade discount price for the next version?


#18

I wondered why my Suitcase Fusion wasn’t working at all, and now I know!

I can’t even activate any of the fonts permanently or temporarily as they activate and then 5 seconds later they deactivate automatically - would this be due to the security certificate expiration?


#19

@mattm3
The issue you are experiencing doesn’t have anything to do with the security certificate. The certificate only validates that our panels are authorized to work within Adobe CS/CC applications.

It sounds like the issue you’re experiencing has to do specifically with font activation in the Suitcase application. I suggest you reach out to our support team so they can gather your environment details, troubleshoot with you and guide you toward the quickest fix.
Here is the best contact info for assistance:
(503) 274-7030 or support@extensis.com


#20

[quote=“CMeyer”]@mattm3
The issue you are experiencing doesn’t have anything to do with the security certificate. The certificate only validates that our panels are authorized to work within Adobe CS/CC applications.

It sounds like the issue you’re experiencing has to do specifically with font activation in the Suitcase application. I suggest you reach out to our support team so they can gather your environment details, troubleshoot with you and guide you toward the quickest fix.
Here is the best contact info for assistance:
(503) 274-7030 or support@extensis.com[/quote]

Oh - I’ll try uninstalling and re-installing the beta version or if the new update is released by Monday I will install that and if it still doesn’t work I will contact support.

Thanks Chris

Matt