Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

Suitcase Fusion 6 Not Working with CS5 (photoshop most specifically)


#1

I’ve had nothing but problems since purchasing SF6, which I will try to outline below:

I work primarily in Photoshop CS5 on a late 2009 27-in. iMac
3.06 GHz Intel Core 2 Duo
12 GB Memory

Was running Snow Leapard when I first purchased SF6, but have since upgraded to El Capitan 10.11.4 - I was having some issues running the old OS, and while upgrading to El Capitan fixed some things, it has had no effect on SF6 issues I’m having. Same problems before and after the upgrade.

Issues:
• Opening Photoshop is very sluggish now. The Extensis window within Photoshop shows ‘thinking’ while loading fonts, then when individual font list shows up, there is a spinning icon next to each font name indicating that it is ‘thinking’ or trying to load or activate fonts. Photoshop takes approximately a full minute to open now. This was not an issue when I was running Fontbook/before installing SF6. See attached screenshots:


• Once I open a photoshop file with any text layers, each text layer within the layers pallet always has the yellow icon with an exclamation point in it, indicating a missing font.
• Every time I click on a text layer in the layers pallet, all of the fonts in the Extensis window have the ‘thinking’ or ‘loading’ icon next to them just like when I first started the program, and I have to wait 30 seconds or so before this stops and I can actually double-click the layer and edit the type. If I have multiple font layers that all need to be edited, I have to go through this process every single time (even if all text layers are using the exact same font).

I am this close to deleting this program and going back to Fontbook, but would like to figure this out so I’m not wasting the money I spent on SF6. Almost impossible to work this way though… Any advice would be GREATLY appreciated. I’ve got a total of about 5,500 fonts by the way - I pulled them all off of my backup drive and loaded straight into SF6, allowing SF6 to copy them into whatever storage folder it uses…

Thanks,


#2

Hi Lab,
Thank you for contacting Extensis Customer Service. You’re probably running into issues because CS5 has no support from Adobe past OS X 10.9. You’ll need to upgrade your Adobe for OS X 10.11 (El Capitan) support. Let us know if you have any other questions.

Kind Regards,
Josh Hallenbeck
Customer Service


#3

Ok, I already said this pretty clearly, but I’m having the same issue now that I was having before I upgraded to the new OS, leading me to believe that the new OS is not the issue that I was/am having.

What specifically needs to be done to make SF6 work with CS5? I.E., plugins, etc - are there things I can check to narrow down this issue? Thanks,


#4

Hi Lab,
There is nothing that can be done to get CS5 and Fusion 6 to work together on El Capitan. CS5 has no support from Adobe to work on El Capitan, so we can’t build compatibility for that that configuration in Fusion 6. If you roll back your OS, or upgrade your Adobe to CC 2015, Technical Support should be able to troubleshoot you. Until that happens, there is no supported path to get it working.

Kind Regards,
Josh Hallenbeck
Customer Service


#5

i had the same problem. i use only cs5 (newest osx) i started some days ago that in indesign and photoshop many fonts that were organzed by suitcase (newest version) were not listed. arghhh… i think i updated suitcase to the newest version and then it started to get buggy,
i tried several things, but after testing fontexplorer with same problems i tried so cleaned the font cache(s), and this helped! ow my old macbookpro from 2007 runs much fatser, amazing,


#6