Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

Suitcase Fusion 6 not managing System Fonts > Local


#1

Since upgrading to El Capitan (OS 10.11) Suitcase Fusion 6 (17.3.2) can’t seem to be manage any of the fonts that are listed under System Fonts > Local. These are the fonts that are housed in the Library/Fonts folder. (I’m not talking about the fonts that are listed under System Fonts > System, which are all locked permanently ON.)

When I initially launched Suitcase, there were a number of fonts that were already ON and showed up with a green dot. They were not locked, just active. When I select a font and Deactivate it, the green dot disappears. So everything appears to work.

But then when I launch an app (CC 2015 InDesign, CC 2015 Illustrator, Word 2016, etc.) all the fonts that I Deactivated this way still show up in my font menus are fully functioning. (Note that this doesn’t appear to be related to sandboxing, which is a whole issue on it’s own.)

I tried restarting my computer. The fonts appear as Deactivated in Suitcase but still appear in font menus. I tried deleting my prefs, my font vault and other Extensis files and started again. No luck. I can add fonts to my Font Library and turn them on and off without any problems, it’s just the System Fonts > Local fonts that Suitcase can’t seem to manage.

Anyone else experiencing the same issue? I don’t see any similar topics.


#2

Hi Eric,
It sounds like you may want to adjust some things in Font Book. Check out our Knowledge Base below, and if you are still having trouble, please contact Technical Support.
http://www.extensis.com/company/contact-us/
https://help.extensis.com

Kind Regards,
Josh Hallenbeck
Customer Service


#3

Nope, Font Book wasn’t the issue. I already had it disabled. In addition, I already cleaned out my Library/Fonts folder of most of the 600 fonts that existed there – put there by previous versions of Adobe CS and MS Office. I’ve now whittled it down to just 16 fonts required by Adobe apps.

In short, the OS and 3rd party apps seem to be requiring more fonts all the time and they’re making it so you can’t deactivate them with Suitcase. Suitcase shows I have 279 required System fonts that are permanently locked on. Adobe also seems to require another 16 fonts, as described above, which are locked on as well. Throw the increased use of sandboxing into the mix and font management apps are becoming less relevant when it comes to controlling OS and sandboxed app fonts.

Suitcase still works perfectly well for activating fonts that I have outside of core OS folders, but it seems like user-enabled font management is starting to be limited. I guess I’ll just have to get used to scrolling though reams of font names in endless font menus. Microsoft Word is just getting ridiculous and Illustrator isn’t much better. At least InDesign has a “Favorites Filter” that allows me to minimize the viewable font list though.


#4

Hi did you ever resolve this issue. I had the same with fusion 6 and now 7. I tried to take more control with 7 I know the fonts in the local library aren’t activated but they always show up in the adobe applicationd.


#5

Unfortunately I’ve just had to accept the horrible state of font management on my Mac. I guess it’s just a sign of the times. Plus, I don’t have admin privileges on my computer and I have to call my IT dept every time I need something done so I’ve just given up. Every time I have software updates the same fonts end up getting re-installed again so there’s no point calling IT to remove them. So now I just use Comic Sans for EVERYTHING. Ok, just kidding there, but it does make working with fonts more frustrating.


#6

Thanks for your questions. We have written a guide on Font Management Best Practices. For more information please visit the link below:

If you have more questions, please contact one of our Technical Support Representatives using the link below:

https://secure.extensis.com/technical-support


#7

The issue I have is that I don’t have admin privileges which means I don’t have the ability to change anything in the System/Library/Fonts folder (at 89 fonts) or the Library/Fonts folder (at 209 fonts). So I can’t do most of what the Best Practices guide says. If I could manually strip the unnecessary fonts out of these folders I would, but I can’t. In the past, Suitcase allowed me to deactivate the fonts in these folders that were not required by the system (as opposed to the required fonts which are locked in the Permanent ON position). For example, I currently have the “BirchStd.otf” font deactivated in Suitcase but it’s still active in all of my running apps (InDesign, Illustrator and Photoshop, Word, Excel, TextEdit, etc.). So Suitcase is not managing these fonts anymore, even though the Suitcase interface says they’re deactivated. This applies to about 50 other fonts too.