Suitcase Fusion 18.2.0 + Adobe Illustrator 2017 Plugin?


Hi there…

I just updated all my Creative Cloud apps… all seem fine… but there doesn’t seem to be any auto activation plugin for Adobe Illustrator 2017.

When will that become available…? I will even try a beta version if needs be to get this feature back working.



Hey Anthony!

We released Suitcase Fusion 7 18.2 this morning with updated plug-ins for CC 2017. You can grab the latest installer from here:


Or you can select Check for Updates via the Application menu and Suitcase will update for you.

Thanks for using Suitcase Fusion 7!



Hi Clint… I actually did the full install but for some reason it wasn’t showing a plugin for Illustrator… I shut down my computer and restarted… launched Suitcase again and went to Manage Plugins and it was there all selected and installed for Adobe Illustrator… so all working great now. Great job by the Team in getting the release out today!!! Nice one!!!



Great to hear you are all up and running, thanks for the kudos :slight_smile:



Hi again Clint… sorry to bother you again… but on another topic… what has happened to Desktop Typekit Fonts… I don’t seem to be able to locate them on the Typekit library portal site… they all only seem to be Web Fonts… are the Desktop fonts still there and how can I filter them out only…?



Hey there!

I am not sure what changes they have made to TypeKit tool for 2017. I think you should contact Adobe with your question as they will be best suited to be able to help you.

Thanks for using Suitcase Fusion 7!



After upgrading to CC2017 and updating Suitcase to 18.2.0 and installing the new plugin, I get an error message when launching Illustrator telling me there’s a problem with the plugin and that it’s been disabled. What’s that about?


Hi Sam,

Thanks for contacting us about the plug-in issue. These issues are usually caused by an older or incorrect plug-in version being installed in your Adobe plug-ins folders. Please try the following steps to see if it can be resolved:

  • Close all Adobe applications
  • Then locate and remove ALL the previous version(s) of the Extensis plug-ins from the following location(s): Application/[Adobe Application Name]/Plug-ins/Extensions/ExtensisFont…
  • Restart your computer

Once they have been successfully removed, open the Suitcase Fusion application and select the Suitcase Fusion drop-down menu in the upper left corner next to the Apple menu. Then select Manage Plug-ins. Select the Adobe versions of the plug-ins you would like installed and click Done. Now launch your Adobe application(s) and see if everything is working as intended.

If the above steps do not work, please contact our Support Team by clicking the “Online Contact Form” on the right side of the page using the link below:


Extensis Support