Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

[solved] Postscript name does not match display name in Suitcase Fusion


#1

I have several fonts, in same family but different weights/styles, which show the same display name.

When trying to activate each of these fonts in Photoshop, for example, I get an activation error.

The postscript name shows the weight/style. For example:

NameOfFont-Medium

How can I get Suitcase Fusion (or Font Doctor) to fix this? Is there a 3rd party tool I can use to help correct this problem?

Thanks!


#2

It is possible if they have the same name, then they will not be able to activate at the same time since they share this similarity.

Can you share a screenshot of the fonts in Suitcase Fusion?

Extensis does not make products that modifies fonts. Due to licensing issues, you would need to contact the font manufacturer for a newer version to fix this issue. Or, find a newer TrueType or OpenType font if available.


#3

Ahhh, that makes total sense.

In this case, the fonts that I see problems with were fonts I got from the internet. I think I will just trash them rather than try to modify their metadata.

Seems like any font worth keeping would not have this issue.

Thanks so much for your help!


#4

So, I have this same problem - but maybe on a larger scale

I have nuuuuumerous fonts with the same identical name, but clearly they are a set of bold,italic,light,condensed, etc.

And, you can see top right in my screenshot, the postscript name is still there, hiding.

How can I restore the display name to the postscript name?

…this thread is marked solved, but I think that’s a bit misleading as mhulse chose to avoid the real problem by deleting the “duplicate”.

Thanks!


#5

Honestly, I’d love to solve this issue, still… Really does make font management suck when you know you have good fonts with bad names (at least, in the eyes of the font management software). Wondering why Font Doctor doesn’t help to solve this kind of problem? Or, a simple option to use postscript name.