Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

SF5 and CC2015


#1

I have SF5, can someone tell me if Extensis will be offering a free update to handle CC2015 or should I purchase SF6?


#2

Ditto. Cant access the panels since the new upgrades to Illustrator and Photoshop 2015. :cry:

Any news or fix please, Extensis? :slightly_smiling:


#3

Extensis will not be updating Suitcase Fusion 5 to add Adobe CC2015 plugins. We will be releasing plugins for SF6 as soon as they’re ready.

blog.extensis.com/adobe/extensis … d-2015.php


#4

Thanks for that information; I will have to upgrade to SF6


#5

[quote=“Romeo Fahl”]Extensis will not be updating Suitcase Fusion 5 to add Adobe CC2015 plugins. We will be releasing plugins for SF6 as soon as they’re ready.

blog.extensis.com/adobe/extensis … d-2015.php[/quote]

Thanks Romeo for the link. I had posted a question in the comment section of that post yesterday asking a simple question if SF5 was going to be supported but my comment was awaiting moderation and still hasn’t appeared. Thanks for confirming this.

It seems every time Adobe updates Creative Cloud with a major release (i.e. CC2014, 2015 etc) that only the latest version of Suitcase Fusion gets the required plugin upgrades to continue to work. Why Extensis?! Poor service.
I’m getting a little dissatisfied having to keep upgrading SF just to keep the Adobe plugin current, especially when without warning, the plugin stops after each new CC release. Then the same old wait for “several weeks” while “we make the latest version completely flawless”. I’m using the plugin for business and each year this seriously disrupts our work flow. I cant believe this can encourage people to incorporate SF/ CC plugins into our workflows and keep upgrading when this continues to happen. There must be a better way to resolve this each time, at least give us some warning so we can prepare for it. Adobe pretty much forces us to remove the previous versions so I have done so, but a heads up before hand by Extensis to warn us why we shouldn’t do this would be useful.
I’m now stuck without the working plugin, with a vague resolution timeline that I’ve no benefit from because I happen to have the “older” version and not current version which I have to keep on buying each time. Not the best customer service, Extensis.

Disappointed there’s still no resolution.