Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

SF 6 not compatible with Quark 2015 in El Capitan


#1

I have been a QuarkXpress owner since 1989 and have used all versions thru Quark 10. On Oct 14, 2015 I purchased and installed Quark 2015 version 11.2.0 (compatible with El Capitan OSX 10.11) on my Mac Pro (late 2013).

Just prior to this, I had updated my Suitcase Fusion 6 to version 17.3.0, which is also compatible with El Capitan.

THE PROBLEM:
When I open my legacy Quark documents the text boxes are empty. The font is “On” in Suitcase Fusion 6, and the Quark Utilities “Usage” shows that the font is associated okay, as well. In addition, the document preview pane in Finder shows the layout and type look perfectly okay. But when the file is actually opened – the type box is empty in each document. Note: the layout is very simple, one 11x17 edge to edge photo with one text box headline over it.

STEPS I HAVE TAKEN:
I called Extensis tech support and was told that this is “a known problem” with both Quark and Extensis, but that they have no idea who or when this is going to be fixed.

They suggested a work-around:

  1. Uncheck and disable the ‘Auto-activation’ plug-in with the Suitcase Fusion 6 ‘Plug-ins Manager’.
  2. Manually ‘turn on’ the font in Suitcase Fusion 6.
  3. Drag and install the font file I want to use into the OS X Library Font folder.
  4. Reboot Quark.

I only tried this once, and it worked.

Today, I received a response to a post in the Quark forums from the Quark rep there, who said that it was up to Extensis to supply a fix. So the big question is, how long is this going to take? This is a very big deal. Because with thousands of fonts being managed by my Suitcase Fusion 6, I can’t really use Quark 2015 until this is fixed. – respectfully, djt


#2

I hear ya DJT… I’m in the exact same situation… I’m manually activating my fonts now as that does work… it’s only the auto activation that’s broken… but it’s really not clear who’s issue this is and who’s going to resolve it in the near future. I too like things just working correctly and it’s very frustrating when things that worked perfectly before don’t work the same again… extra clicks and app switching is all extra time we are all trying to cut down on.

You should have to drag files into the OSX Library Font folder… manual activation from Suitcase has been working fine for pain… and added pain but working. Extensis aren’t great or quick fixes or even posting that issues exist… so not sure when they will resolve this… I can only guess it could be after the new OSX 10.11.1 update (which should be out any day now)… as Apple might implement a new code fix here that could throws matters out again… who knows… :frowning:

Sorry I couldn’t be much more help… but I FEEL YOUR PAIN!! :slightly_smiling:

Regards,
Anthony


#3

Extensis tech support SF6 sent me an email Friday with a diagnostic tool and instructions for sending them detailed info via their FTP site. I was only able to finish responding by Sunday as I included a detailed description of what does and does not work, plus I had to collect sample docs, files, etc.

Since then, Quark 2015 suddenly decided to crash on launch for no particular reason - every time. I sent screen shots of the crash reports to Quark tech support. They responded this morning with this:

“I have analyzed the crash reports sent by you and it seems that the issue is occurring with one of the fonts present in the computer.”

He then proceeded with a very long complicated and time consuming instructions to find the font causing the corruption. Here’s the thing, I can save hours of aggravation, because obviously it is the same font I had to manually install into the OS Fonts folder when it wouldn’t show up in the Quark text box. Which worked, until the latest Quark crashing.

Separately, the way I got Quark to launch again, was to run the Apple Disk Utility, which did the trick.

The Quark Forum rep suggested I delete the Quark Prefs from the Library and disable the Extensis extension from the Quark Xtensions folder. The thing is, that extension doesn’t exist in any Quark folder, even after a global search. So I can’t disable what I can’t find on my Mac. I’m thinking disabling the Quark auto-activation plug-in may have deleted it, not sure.

Here’s a copy and paste of the Quark tech support instructions - (which I have no intention of doing, as I can simply drag out the font I dragged into the OS Fonts folder):

Step 1:

• Safe Boot your computer by holding down the Shift key while turning on or restarting your computer. This method runs Mac OS in Safe Mode. Launch QuarkXPress and test the features that had failed. If QuarkXPress works correctly, quit the application. Then Restart your computer.

Step 2:

• Quit QuarkXPress
• Launch ‘Font Book’ under applications.
• Select all fonts.
• Go to File > Validate Fonts.
• Remove all the fonts which are corrupt. [Note: You will need to reinstall the corrupted fonts after you remove them.]
• Re-launch QuarkXPress.

Step 3:
Note: Quit QuarkXPress before starting the process below and disable any font management utility like- suite case fusion, Font agent pro etc.

** It is possible that the Library folder is hidden on your system. To display this folder navigate to the “Go “menu item in the menu bar at the top of your screen. As the drop down appears, press and hold the “Options/ALT” key of your keyboard, the library will appear in the list.

  1. Create two folder’s named “User Fonts” and “Library Fonts” on desktop.
  2. Move fonts from the following location to their respective folders on the desktop.
    User Fonts: Mac HDD > Users > Current User > Library > Fonts.
    Library Fonts: Mac HDD > Library > Fonts.
  3. As a next step, you need to move first 20 fonts or 1st 2 alphabet fonts from “Library Fonts” desktop folder to Mac HDD > Library > Fonts.
  4. Launch QuarkXPress and see if the problem still persists. If it works fine, then move another 20 fonts or another 2 alphabet fonts from “User Fonts” desktop folder to Fonts folder (Users > Current User > Library)
  5. Continue the same process until you find the culprit font or culprit set of fonts.
  6. Relaunch QuarkXPress every time to check the successful launch of QuarkXPress after every move of fonts to Fonts folder.

BOTTOM LINE: Quark and Suitcase Fusion 6 are not compatible with each other in El Capitan. This is probably going to take a very long time to work out because it involves two different third parties, and to whatever degree they have the resources, I doubt they are talking to each other much, if at all. I have been wasting hours and hours on this Quark-Extensis mess. I am walking away from Quark until I hear back from Extensis tech support.


#4

I hear ya djt… but for me… QuarkXpress is too important to my business… so I will just stick with the inconvenience of having to manually activate my Quark Document fonts and hope that the power that be get their act together and solve this for this customer sooner rather than later.

Regards,
Anthony


#5

" I will just stick with the inconvenience of having to manually activate my Quark Document fonts"

I think the issue that I ran into related to that is, with just one font being dragged into the OS Library Fonts folder, according to the ‘crash report’ that a font was causing the crashes, and that being the only change I made to the Apple Library Fonts folder – apparently that font caused Quark 2015 to crash.

That being said, running Apple Disk Utility fixed Quark from crashing, for the time being. The new Disk Utility is different in El Capitan in that it no longer “fixes Permissions” but instead runs a ‘First Aid’ fix of some kind.

The caveat here is that I had already run it earlier, but after using DiskWarrior to rebuild the Directory, and resetting the PRAM and SMC. So it’s hard to say what fixed what, except that Quark 2015 starting crashing again later for no apparent reason.

I also did one more thing once Quark was launching again – I dragged the offending font out of its “Collected Fonts” subfolder so it is now one step up in the font hierarchy in the Library > Fonts folder. Don’t know if that’ll make any difference or not, I’ll have wait to see if Quark crashed again… I haven’t actually used it because I’ve been so busy dealing with all this nonsense.

Anyway, I have yet to delete the Quark 2015 ‘preferences folder’ as the Quark forum rep recommended, because first off I’ve done very little as far as changing the Quark prefs, and second, I think it’s smarter to just wait until Quark crashes again, so that I can assess a correlation if it happens and deleting the Prefs fixes it.


#6

Will this Quark not working with Suitcase Fusion even be fixed…?

Any update please from Extensis staff…?

Regards,
Anthony


#7

Extensis emailed an announcement today that their Font Doctor has been updated for El Capitan. But no word yet on their Suitcase Fusion 6 ‘fix’.

They also have posted a “work around” that essentially reiterated how Suitcase Fusion should be installed by default – with the Vault in the 'Home" folder" and all post script 1 fonts should be ‘in place’ in the vault.

I’ve read these suggestions several times, and like much of what they say, it is exactly how my system is already setup, so their suggestions to fix the incompatibility issues are pointless in my case:

extensis.com/support/knowled … l-capitan/

MY SOLUTION:
I manually turn fonts on and off, by circumventing Suitcase Fusion 6 from controlling all my fonts by “adding fonts” to the OS X El Capitan ‘Font Book app’ – as I need to use them. Interestingly, I still keep SF6 ‘on’ in the background to no affect one way or the other, as it is pretty much useless now. But the fonts I turn on directly with the OS X Font Book app at least show up Photoshop and Quark now. So I can use those apps again!

One caveat: the WYSIWYG font memes are completely messed up, because they display all the fonts I had on in SF6 before, but they do not all actually work. The only ones guaranteed to work are the ones enabled in OS X Font Book app.


#8

Cheers for the reply and update djt… very much appreciated.

For me really… the only issue is the auto activation plugin not being compatible with QuarkXpress 2015 (latest version). I can manually turn on and off my legacy font grouping sets in Suitcase Fusion without issue and preview all my fonts etc… but the manually having to activate and the poor communication from Suitcase in relation to a fix… by them of Quark is really poor customer service in my book. I wouldn’t get away with it in my small business…

Thanks again and I’m glad you had some workaround that has you in production… :slightly_smiling:

Keep the faith!! as they say!!

Regards,
Anthony


#9

All,

It was unexpected that the 11.2 update would affect the functionality of our QXP 2015 plugin.
We are committed to fix it as soon as possible.
The work has been queued up but I can’t provide a fix date until we determine the root cause. We will work directly with Quark to resolve the problem as necessary.
The Extensis plugin team is finishing up another project over the next couple weeks and will get to this plugin fix right after.

I will update this forums post when I have something to share. Sorry for the delay.

Cheers,
Chris


#10

A Very Happy New Year to all the team at Extensis…

Hopefully the essential update of Extensis to allow for the auto activation of font inside Quark Xpress 2015 and stop the consistent crashed of this core app will happen sooner rather than later.

I feel we as an online/loyal forums community have been very understanding about this ongoing issue… but it’s been months now… can you please update or inform us as to when this essential fix will happen…?

Best regards,
Anthony McCarthy


#11

Don’t hold your breath. Loyal SF6 customers like us are a low priority at Extensis. They prefer to spend their resources on promoting and advertising a faulty app than actually fixing it.


#12

Thanks CreativeAnto,
Happy New Year to you and the others monitoring this post.

We continue to work on this issue - it is our main priority for Suitcase customers.
We’ve had an ongoing dialogue with Quark Engineering (admittedly slowed over the holidays) but is back in full swing.
Unfortunately, neither development team has been able to figure out the root cause for this crashing issue yet.

Extensis is currently considering a complete plugin re-write as a long term solution while still investigating short term ways to resolve the problem.

My plan is to update this post later in the week once my developers have made further progress.
Also, I’ll hand off a plugin for you to test as soon as possible.

Cheers,
Chris


#13

Cheers for the reply Chris… it;s first day back here in Ireland after the Xmas Holidays… so we are all allergic!! :slightly_smiling:

Great to hear you guys are back on the case… and that a work around is in the pipelines and soon to be released. Longterm the plugin re-write might be the way to go… but I’ll take any patch fix for now to resolve the crashing issue and have my fonts auto activated!! :slightly_smiling:

Again… thanks for the communications update. Very much appreciated.

Regards,
Anthony


#14

Include me and my production team on the list of people who need SF6 to work with Quark 2015.


#15

Suitcase Fusion 6 Version Version 17.3.1 (638033) has been released… and it looks like it’s a fix for the auto activation of the fonts inside QuarkXpress 2015!! YIPPEEE!!! :slightly_smiling: HAPPY NEW YEAR ALL!!! :slightly_smiling:

Regards,
Anthony


#16

Hello Anthony,

Unfortunately the 17.3.1 release doesn’t address the QXP2015 plugin in El Capitan crash issue. While it would have been a wonderful surprise if it does the problem still exists.
17.3.1 addresses the following:
Fixed an issue where the Extensis Font Panel would fail to load in Adobe CC 2014 and CC 2015 applications due to an expired security certificate. [UTS-4556]
Fixed an issue where the Extensis Font Panel would not display any fonts after updating to Adobe Creative Cloud 2015.2. [TS-2085]

We continue to work on the Quark issue and will get that update to you as soon as possible.


#17

Keep your fingers crossed…

I have spent this evening checking Quark2015 and the new plug-in on an external drive which has El Capitan.
I still get a message that some of the fonts are missing, but, when the file is fully open, all are in fact present and correct. (This message has appeared ever since I got Fusion 6, by the way, and I have mentioned it before; it is a nuisance.)

So far, then, so good.

I also upgraded Fusion 6 on my Macbook (running Yosemite) and not a font would activate until I binned Fusion 6 and reinstalled it, followed by today’s upgrade. (Again the ‘missing fonts’ panel appears, but the fonts are in fact showing correctly.)

I’ll check some more files tomorrow, but I think you’ve got the plug-in working at last!


#18

Checking more files. Opening Quark first and then a file: the right fonts appear.
Double-click the file to open it and the fonts are missing; no auto-activation.

Other users report Quark crashing on quit; I don’t get any message on screen, but checking the Console records show a crash report is generated. (You know all about that problem.)


#19

Hi Shaun…

I too am experiencing a fix of sorts. I always open my Quark App first, just force of habit… and I have experienced that complex Quark documents with multiple font version are opening without any alert messages… so that’s great… but I do get a Quark Crash folder also on first Launch and quitting maybe also… I will need to concentrate better on what happens when and log the issue in a new update… but this SF6 update has brought some hope to a fix.

Regards,
Anthony


#20

Hello all,

Quick update -
We are nearing the completion of our plugin addressing the QXP 2015 crash issue in El Capitan. Things are looking good and I should be able to hand off a version for you to test soon. After I receive feedback and my QA Engineers give the thumbs up I’ll get the official release out the door.

I’ll will update this post next week with the installer info.

Let me know if you have any questions.

cheers,
Chris