Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

Preferences reset when re-launching Suitcase Fusion 18.0.6


#1

Every time I relaunch Suitcase, whether after a restart or for any other reason, it asks me all the setup questions re font vault, system fonts etc. It’s quite annoying and I’m wondering if there is some way to stop this behavior? I would like to just be able to set y preferences and have it done!


#2

Hi gopabear,

You should certainly be able to set your preferences and have it done. I suggest contacting Technical Support for help: https://www.extensis.com/company/contact-us/.


#3

Did you ever get this resolved?
I have a user with the exact same issue.


#4

No. They suggested I upgraded to the latest build. I did, but then InDesign cc2015.5 couldn’t see the plugin. So I downgraded and decided to live with it. grrr.


#5

Hi!

Is it possible that you have the permissions somehow set to not allow you to write to the preferences folder? Once the preference file is created you shouldn’t see the initial startup wizard again.

With all the sandboxing and various security changes to the newer versions of OSX it is possible the file isn’t being saved correctly.

Check here, select Go To Folder from the Go menu and type ~/Library/Preferences

Do you have a file titled com.extensis.SuitcaseFusion.plist?

If not it means that Suitcase is unable to write to that directory, if you do have a pref file with that name, could you send me via a private forum message and include the preference file and I will take a look at it.

I am assuming you are on Mac as you posted in the Mac forum but if you are on Windows we will have other things to look at so let me know.

-Clint


#6

Hi, I do have a preference file, but I don’t know how to send a private forum message or attach it. Can you help?


#7

Hi gopabear,

To send a private message, click on the recipients name in their post. In the window that pops up, click Message. In the message window tool bar, click on upload icon - it’s the little computer with the up arrow. Browse to and choose your file and click the upload button to place a file link in your post. Please use a .txt file.


#8

com.extensis.SuitcaseFusion.txt (4.8 KB)

mmarsden,
I am having the exact same problem as gopabear. I have attached my suitcase fusion preference file for your review. I am working on an imac, El Capitan 10.11.5, Suitcase Fusion 7. Let me know if I can provide anything else.

Thanks!


#9

Hi!

Thanks for providing the .plist file. It looks like the file is not being updated correctly. I suspect it is due to a permissions error causing Suitcase to not be able to write to the com.extensis.SuitcaseFusion.plist.

You can check the permissions on the pref folder and the file to make sure you have Read/Write access to the file or as a quick test copy the com.extensis.SuitcaseFusion.plist to the desktop, remove the one in the Preferences folder and launch Suitcase.

This should create a new preference file for you (you will have to go through the first launch dialogs again ;)). After that subsequent launches of Suitcase shouldn’t bring up the first launch dialog. If this fixes the issue we will know for sure that the permissions are not set correctly on the pref file.

Let me know what you find and thanks for using Suitcase Fusion 7!

-Clint


#10

Removing the preference file from the folder and restarting to test (a few times) as you suggested, resolved my issue. Thank you!


#11

Hi!

Glad that helped clear up the issue for you. As a side note the original issue gopabear was having as well as yourself was related to the preferences file not having the correct permissions.

The settings for the permissions file should be:

(Me) - Read and Write
everyone - no access

Just in case anyone else out there runs into the same issue.

Thanks for using Suitcase Fusion 7!

-Clint


#12

Is it possible to get the steps to locate permissions on my hard drive so that they can be corrected to read and write? I did a search for file name “com.extensis.SuitcaseFusion.plist” and got 0 results and with my search for a preferences folder, I was unable to locate one specifically for suitcase.


#13

You will find it at: User – Library – Preferences. You may need to make your user library visible first. Here are instructions: https://www.macobserver.com/tmo/article/mavericks-easily-make-user-library-folder-visible


#14

Thank you so much! Things are working and file viewing is back to normal!!!