Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

No longer able to activate/deactivate any fonts with Windows 10 Anniversary Update


#1

I am running the new Windows 10 Anniversary Update that just came out this week.

I am now unable to activate or deactivate any fonts that were not previously activated or deactivated. (i.e. when I click “Permanently Activate” on a font that is not active, it activates and then immediately deactivates. Similarly, when I click “Deactivate” on an active font, it deactivates an then immediately reactivates.)

This is happening on BOTH computers I am running Suitcase Fusion on, and BOTH of them are running the new Windows 10 Anniversary update.

Anyone else having this issue? This is directly affecting my ability to work, and I have deadlines…!!!

thanks
Dan


#2

Hi Dan,

Windows 10 made a few changes that can sometimes cause issues with a current installation of Suitcase Fusion 7. I suggest an uninstall / reinstall of Fusion and that should take care of your activation issue.


#3

Yup - that did it. Thanks!


#4

Same question here… and the uninstall / reinstall seems to have done the trick.


#5

Out of interest are you having any further problems since the AU? I’m having major stability problems with windows when my fonts are temporarily installed? (Admittedly quite a large library). Same problem on my tablet and desktop. Was never an issue prior to the AU. Have also been trying to escalate the issue with Microsoft but no joy from anywhere as yet (Same problem with other font managers).


#6

Mike,

This has been an issue for a while now with updates to Windows. Any chance Extensis could drop a small utility in the Program folder that would re-register whatever gets un-done when a Windows update gets pushed through. I’m sure by now you guys know what it is that is causing the issue.

Just seems a little outdated to have to uninstall and re-install with every update. Maybe it could even be baked into the app in the help menu or something.

Thanks.

–Sean


Fonts activate for a second then deactivate automatically (Win10)
Adding fonts issue
#7

Hey Sean,

If they keep resetting the registry keys when they do updates we will figure out a different solution. I suspect this is due to increased vigilance on Microsoft’s part when it comes to security.

I understand it is a hassle and I appreciate you taking the time to give us feedback. We will keep an eye on the next update to see if it causes the same issue.

Thanks!
-Clint


#8

Clint -
Can you give us any idea how much longer we need to wait for a fix on this? I’ve had to reinstall suitcase three times in the past six months. It’s getting old.

Thanks,

Terry


#9

Hi Terry,

Well this is a tough one actually. We have to open up permissions on a couple of registry keys to allow activation of PostScript fonts. Microsoft has taken a stance (this is recent and probably due to security issues they have) of resetting registry permissions on certain updates.

This is why running the installer fixes the issue as the installer is authenticated and trusted to modify registry keys. We don’t have an easy way (without opening potential security holes) of modifying these entries on application launch.

I appreciate your patience and I know this is a hassle and we will continue to work towards a resolution that doesn’t require a reinstall as quickly as we can.

Thanks!


#10

Thank you for letting us know that we are being heard. I know it must be
frustrating for you guys too.

I’ve been an avid Suitcase user for many years, but…


#11

Question: Would a small utility, that runs with the same permissions as the installer, be possible? It’s sole purpose would be to reset the permissions on the registry keys without a complete uninstall / reinstall. It could be placed in the app’s directory. Maybe instead of launching or resetting the Registry on product launch, you just check the permissions. If they are not what they need to be, you inform user that an update to windows has occurred and the utility needs to be run to fix the issue. Not an elegant solution, but might be a compromise for now.


#12

Yep, this is certainly an option and something we are looking at. I am hopeful we can, at a minimum, work around it so folks don’t have to spend time installing the app when they don’t need to.

Thanks for the suggestions and feedback, we really appreciate it!!

-Clint


#13

Any update on this?

–Sean


#14

Still wondering if this is going to be fixed or a utility provided to workaround a complete re-install.


#15

You do NOT have to uninstall and reinstall to get it working again.

This works for the latest “Creative” update.

I was able to run the installer, select MODIFY and continue.

I did NOT restart after the modify install. I immediately opened up InDesign. It loaded my fonts perfectly.


#16

run the installer, select MODIFY and continue

I want to thank slgooding for this fix, and note that it works for me as well.

I first encountered the problem (my CS5 version of InDesign crashing on start-up, due to font issues, every time I tried to load a file) with the Windows 10 Anniversary Update in August 2016. Back then, I thought the problem was related to the very old font management program I had used for years (Bitstream Font Navigator, a free app with CorelDRAW), which was never really supported, nor was it updated. New versions of BFN were issued with new versions of CorelDRAW, but for all intents & purposes, it was basically the same program. BFN didn’t work all that great with Windows 7. It worked much better with Windows 10, but come August 2016, when InDesign started failing, I figured BFN was no longer compatible with the new OS, and that it was past time to move on to something else.

I was only able to get InDesign up & running again after I began editing the Windows 10 registry directly myself, purging a couple thousand fonts from my system, doing a clean reinstall of the Windows 10 system fonts, and adding my own code to the registry to activate a core group of additional fonts which I can’t live without (for several reasons, I don’t use the Windows Control Panel font installer for this).

Editing the registry is extremely tedious & time-consuming, so I began researching font management programs, which led to a trial run and purchase of Suitcase Fusion 7 in July 2017. It took me a long while to set it up properly (I have about 3700 fonts on my system, all of which I needed to reclassify and reorganize into Fusion 7 sets, etc.), completely transforming my work flow in the process (I didn’t used to “temporarily” activate fonts, which changes everything). After spending so much time setting up Suitcase Fusion 7, I was not happy when InDesign began crashing again on 11/15/2017, after another Windows 10 update on the 2nd Tuesday of the month, 11/14/2017 – just like happened before with Bitstream Font Navigator.

Because I don’t use the Font Vault (and have no idea where Fusion 7 keeps my settings – such as tags and styles – for individual fonts and sets, so that I can back up these files separately), I was worried that I would lose weeks’ worth of work if I had to uninstall and reinstall Fusion 7 this week … let alone having to do this every time there is a major Windows 10 update!

slgooding’s fix averted this looming disaster, and I am so grateful! :wink:

Now, can anyone tell me where my settings are stored, just in case I ever need to fully uninstall/reinstall Fusion 7 in the future?

I’m assuming that I can’t just back up to the cloud with TypeSync, or use Suitcase Fusion’s Font Vault Archive feature, because I have chosen not to use the Font Vault (my preferences are set to “Added fonts are left in their original location”).