NetPublish site not found on new server


I am trying hard to migrate existing Portfolio configuration from a 10.7.4 MacPro (2008) to a new MacMini Server with 10.9.1. After two “attempts” still without succes (no problem however with Portfolio Client and Server). It is NetPublish that gives me the problem. My first attempt was using Apple’s Migration Assistent, which worked fine except for NetPublish. My second attempt was the migration procedure as suggested by Extensis: extensis.com/support/knowled … er-server/

Unfortunately same result (everything works except netPublish).

Situation at this moment: At this moment I have two (only for migrating/testing purposes of course) Portfolio Servers (incl. NetPublish Server) active in our network, namely on the old MacPro (10.7.4) and the new MacMini (10.9.1).

What did I try today:
On the new clean installed MacMini with 10.9.1:
Created a new (first and only) catalog. Used NetPublish-wizard to publish a site of this new catalog. The last step of the wizard congratulates me and gives me a button to view the site. When I click on the button following url opens in my browser: Unfortunately the url is not found.

Then (still on the MacMini) I added (in the last step of the NetPublish wizard) the “old” netPublish Server (the one on the MacPro) as a second NetPublish Server and published my site to this server. Guess what: site publishes OK on the old server, without any problem.

Question here is: what goes wrong on the new MacMini Server?


Have you enabled the Web service? Netpublish requires Apache to be running before it can do anything.

On OS X Server, you just enable the Web service. Do not enable the Wiki service unless you change its default port first, otherwise its port will conflict with one that Netpublish also requires.

If you’re on the desktop (non-server) version of OS X, you can use the solutions in this KB article to start Apache:

extensis.com/support/knowled … 0-8-later/

You may need to restart Netpublish from the Netpublish Launcher after starting Apache.