Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

Gibberish fonts in browsers


#1

Hi,

I originally purchased Fusion 3 a couple of years back but after experiencing font issues in my browsers all the time, I uninstalled the app and ended up never using it.
Fast forward 2013, I decide to give the upgrade to Fusion 5 a go. Since my Fusion3 experience I have a new OS version, a new computer and the new Fusion 5 release, so I figured that problem would be gone… but unfortunately, it’s the same problem all over again.

In my browsers (Chrome, Safari), some headline fonts are replaced with gibberish fonts or signs, making them unreadable. It’s not with all fonts or headlines and the main text is usually fine, but some titles are screwed up.
I started looking for answers and found people saying that it may have to do with moving system fonts into the vault vs linking to them, or something of the sort. I honestly don’t feel like searching for answers all over the web… again. I am hoping that this is a known issues and, more importantly, that there is an easy fix in the forums here… (my search didn’t come up with anything)

Does anyone have an idea about how to fix this?

PS: Attached a small sample for the Wordpress dashboard in my browser (notice the issue in the top right corner)


#2

I am also having the same problem. Does anyone have an answer? Some of my fonts look like the previously attached image.



#3

This is usually a sign of having problems with websafe fonts. Both Safari and Chrome are based on Apple’s WebKit engine for font display, which can have issues if you override the websafe fonts of the OS with your own versions, which often happens when using a font manager. We’ve seen this issue be fixed in updates to Google Chrome, only to reappear again in a newer update. The choices are either to try a different browser that doesn’t use WebKit (e.g. Firefox), or reinstall/reactivate the versions of the websafe fonts (e.g. Arial, Verdana etc.) that come with OSX, which may also sometimes require a ‘clean font cache’ to update.


#4

Thank you for your response. Since I am at a novice maybe you can point me in the right direction.
…“reinstall/reactivate the versions of the websafe fonts (e.g. Arial, Verdana etc.) that come with OSX, which may also sometimes require a ‘clean font cache’ to update”.

How do I go about and do these two things?

Thanks for your help.


#5

Hi. I also struggle with this problem. So far only in Chrome, but as said above, it comes and goes. Would also like more information on how to reinstall the web fonts etc. I’ve tried changing to different fonts in my chrome settings as well, which always works for a little while. I really don’t want to go back to using firefox, so would love to be able to fix it for chrome.

Thanks :slightly_smiling:


#6

There’s not much to say. Deactivate in your font manager any of your own versions of websafe fonts such as Arial, Helvetica and Verdana that might be overriding the system installed versions. Then make sure you do have the original installed version still installed in the OSX System font folders (/System/Library/Fonts & /Library/Fonts).


#7

Ok Thanks. How do I know which fonts are “websafe”?


#8

From a quick Google search I found this list of the most common fonts to be found on Mac and Windows OS, that a web developer would therefore use to ensure good display of text on their pages.


#9

Are they the only fonts of concern? I am a novice at this. Is this a feature that could be added to the program in the future?


#10

I’m not sure what ‘feature’ you would want. These are all fonts that would be installed on a clean Mac or Windows OS, and that’s why web developers tend to stick to them, as they be can then be sure their website will display correctly. The problem your having is due to overriding those system installed versions with your own alternative versions, where the ‘WebKit’ based browsers have been known to have problems that come and go as Apple and Google apply ‘fixes’ to the WebKit engine and the Safari/Chrome browsers. For example see this old issue that we created a KBA for. It was fixed not through our software but i an update to OSX. We’ve seen Chrome updates do similar, only for it to reappear.


#11

Actually, the only fonts I have “installed” are the system. Yet “all of a sudden” I have upwards of 113 fonts in the system and 697 locally. No idea where they came from. I installed adobe CC, Word, etc, Quark and that’s about it. Right now I have added font settings for Chrome as well as Whatfont for Chrome. I was able to stop the problem in Facebook but now anything from Twitter has gibberish. I also shut off what I thought was all of the duplicates. So I am down to one. I guess if I am running your program it would be nice to remove any fonts that are marked as conflicting. Up to this point nothing has shown up as a conflict. Sigh!!


#12

YAHOO! Problem solved! Ok, I felt the obligation to post my findings here after I FINALLY came to the resolve of my problem.

The problem: Same that everyone else was describing, the jumbled characters, I use Chrome and only notice the jumbled characters on the YouTube player. I also noticed that YouTube would use a serif font instead of a sans-serif font sometimes. I could never understand why. I chalked it up to be a missing font that I forgot when I brought over everything from /Library/Fonts or a duplicate or a corrupt font or something.

What I did: So I decided to install a fresh new copy of Mac OSX Mavericks on a VM, and copy the /Library/Fonts folder over to my production machine. There we go, no missing fonts. But I still was having the problem. The thought occurred to me to try Safari and see if I saw the same thing, nope. It was working as intended in Safari. Re-installing Chrome didn’t do the trick either. So it’s obviously something related to Chrome. That’s when I saw this thread.

I disabled Arial (a web safe font) within Suitcase 5, and Chrome wasn’t having any issues after that. Great, but I need Arial. So I removed Arial from my Suitcase Library and put it back in /Library/Fonts along with all the other web safe fonts listed in the link above, and now it works. I don’t know if Extensis or Chrome is to blame on this one, but I am satisfied with this solution.

I’ve attached a screen of how my set up looks in Suitecase. These fonts do not exist in the library and only exist within the System Fonts found in /Library/Fonts. I hope this helps someone else out. Thanks all!



#13

Stevens: thanks for your comment, can you be more specific about the steps to take to how to ensure that the OS fonts are web safe?
I have the same problems- see attached screen. I seem to have it more often in Chrome, but also in Safari. Weirdly, it even shows up outside of browsers - for instance I get rows of question marks in Keynote and Powerpoint docs, sometimes even in Word Docs. I am on a MacBook Pro running Suitcase 7 and El Capitan. Attaching screen shot of typical problem


Thanks!!


#14

We have a KBA here that includes a list of web safe fonts as well as information on managing the issue.