Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

Fusion 7 Guide: "Deactivate non-required System Fonts"


#1

Good day all.

We have installed a demo of Suitcase Fusion 7 and doing some testing prior to upgrading Macs from Fusion 6 to 7.

I am looking to reduce the number of fonts showing up in Adobe software font lists (all the Asian character fonts, for example), and the overall number of fonts the system is burdened with activating. In the past, I actively removed fonts from the System folder following Kurt Lang’s guide, but now in El Capitan it’s become so tricky to remove system fonts that I’m looking for other ways to avoid loading fonts we don’t need. I HAVE removed all except WEB fonts from Macintosh HD/Library/Fonts, but still have quite a few in System/Library/Fonts.

So in the Suitcase Fusion 7 Guide, on Page 25, there is a section titled “Extra System fonts”. This is right after the “Finish” section.

These sections read as follows (I’ve also attached a screen capture):

Finish
You’re ready to start using Suitcase Fusion.
There are a couple of cleanup items that you can attend to now if you choose to.
Extra System fonts
OS X and Windows include many System fonts that aren’t necessary for your computer to function normally. Many of these fonts are extra fonts for specific languages.
To deactivate these fonts now, check the box labeled Deactivate non-required System Fonts.

…I can’t find this “Deactivate non-required System Fonts” box anywhere. Would someone direct me, please?

Thank you!


#2

Thanks for your questions. The option to deactivate non-required system fonts is upon the initial installation of the Suitcase Fusion application. (See image below)

You can also deactivate non-locked system fonts in Suitcase fusion using the following steps:
• Choose Edit > Select All
• Click the gray Deactivate button on the toolbar

I would also recommend taking a look at our Font Management Best Practices Guide. It has lots of helpful information (including required system fonts for MacOS 10.11 and 10.12) that can be found here:


#3

Perhaps this checkbox was missed upon installation. It doesn’t sound like there’s a way to go back and set it.

I have a copy of the Best Practices Guide on my desk; it has been helpful, thank you. I used it to reduce the fonts in the Macintosh HD/Library/Fonts folder, but the fonts used for other languages are the concern at this point.

ALL the fonts in the System folder are locked… I was hoping not to have to mess with the System Integrity Protection to get rid of some of the fonts, but it sounds like that is the only way to reduce font loading.

Thanks.


#4

You are correct. This step is only available upon initial installation.


#5

If I reinstall, would I have the opportunity to deactivate some of those fonts without manually messing with deactivating folder protection?


#6

If you are considering this option, please contact our support team at the link below for full instructions. They can explain the options and what other affects it may have on your application.

https://www.extensis.com/company/contact-us/


#7

I have this same issue. I upgraded from Fusion 6 and that box never appeared when I upgraded. When I did the install, there was an initial install screen as it worked through the process – and then nothing. Maybe 15-20 seconds. Grew impatient and double-clicked the “S” icon in my Applications folder. Suitcase launched. So I never received the “Congratulations” window. Perhaps consider an option for “deactivation” in preferences or perhaps, a “Be Patient” screen during install for the next upgrade.