Fonts will not load into library


New mac, new suitcase. Haven’t installed all my fonts yet, but tried a test run with a couple and can’t get them to work.
The last version of Suitcase I had was 2. Always worked fine. I tried adding fonts to the library in Suitcase 5 the same way I always did in 2 but they do not show up. Checked them with Font Doctor - says they’re fine. Tried using Font Book to add them but it just adds them to the System Fonts folder.
What am I missing? Am I doing something wrong?


I have the same problem. I’m running the latest version of Mavericks and all my software is up to date. This is a new install and before I used Suitcase, I ran FontDoctor on all my fonts to organize and diagnose them.

Nothing happens when I drag individual fonts, folders with a font or several fonts, or use the menu to add fonts. The only fonts available to me through Suitcase are System fonts.


I can get them to work by manually dragging them to the font library, but it makes a new set every time, which is not necessarily what you want. I’m sure there must be another way! Any luck?? :confused:


If you drag a folder onto a library it creates a set with the same name as the folder. That’s by design. If you don’t want a set you should select the library first, then drag and drop into the font list area where, below the previews. This will add the fonts without creating any sets.