Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

El Capitan, SF6 and Postscript T1 fonts activation problem


#1

I get the following error message:
Font activation failed to complete. This can be caused by a problem with your operating system.
For more information, please visit the following URL:

It happens when opening legacy projects that use the Postscript Type 1 versions of:
Courier
Helvetica, Helvetica Bold, Helvetica Narrow
ITC Zapf Dingbats
Symbol
Times, Times Bold, Times Bold Italic, Times Italic
Universal News Commercial Pi
Optima
Palatino
Felt Tip Regular

But no message if I open a TrueType or OpenType version of the fonts only with the Postscript versions that conflict with the fonts in System/Library/Fonts

Mac OS X 10.11
Suitcase Fusion 6 - 17.3.0 (636624)

Is anyone else experiencing the same?


Mac OS X 10.11 (El Capitan) Compatibility
#2

El Capitan, Suitcase 17.3.0 . . still fails on any attempt at activation of any type of font. Help!


#3

I’m having the same issues. Oddly, I created a guest account and installed Suitcase into that, and it activated the fonts no problem. There has to be something we have in common in our systems that is stopping Suitcase from working.

One of the Extensis engineers very kindly got in touch with me and I have sent him over a load of log files from my system. Hopefully a solution won’t be too far away.


#4

Yes, I had the same issue yesterday using a Postscript version of Helvetica Neue. I contacted Extensis and they have opened case for this issue. So far the only solution was to remove the Postscript version of the font from Suitcase and use an OTF version.

Mac OSX10.11
Suitcase 17.3.0
InDesign CC2015


#5

Greetings,

In El Capitan, Apple has changed how applications can access certain locations. This includes locking down access to much of the system. This is all in the interest of keeping users safe.

With these changes, we’ve come across an issue with activating certain types of fonts from any protected locations. This affects users who are adding fonts in place (rather than using the Suitcase Fusion Font Vault) from folders outside of their user accounts control (example Mac HD > My Fonts). There are two solutions to work around this issue:

  1. Add your fonts to the Suitcase Fusion font vault. The vault, by default, is located under your user folder tree and will not be affected by this issue. This is our recommended solution.

  2. Continue to add your fonts in place, but store them under your user folder. Mac HD > Users > [you] > My Fonts would be a fine location.

Note: If your font vault is set to live in a protected location you’ll still be inhibited by this issue. If in doubt, set your font vault location to the default of /Users/[you]/Library/Extensis/Suitcase Fusion/Suitcase Fusion.fontvault

Unfortunately, this is a change that is out of our control so our options are limited in how to address this. Luckily, the solutions are fairly straightforward.

Feel free to contact me directly with any questions or concerns about this.

Thanks!
Ryan C Brown
Extensis Font Team Quality Assurance


#6

My fonts are all stored in the vault. I’m able to activate TT and OT fonts, but no postscript fonts.


#7

Quick follow up… Moving my font vault to the Documents folder allowed me to activate postscript as well as TT and OT fonts.


#8

To follow up with my original post:
I first removed all the fonts from Suitcase Fusion then moved the Fonts folder that had all my fonts (I do not use the FontVault) from Macintosh HD/ to Users/[name]/
Then I reloaded the fonts from moved Users/[name]/Fonts folder
and now the Postscript Type 1 versions of the fonts load correctly in the legacy files.

Thank you Ryan Brown! :smiley:


#9

All my fonts are “in place” and already in my user folder in the original “public folder” for OSX. Haven’t had troubles in other programs but as of today on El Capitan in PhotoShop CS6, I cannot get any (PS or OFT or TT) version of Zapf Dingbats to take and hold when trying to select/change font from Helvetica to Zapf. Oddly, If I do a new layer, start typing standard keys, select Zapf, it sticks… the minute I try to use the Option/Character… it rebounds back to Helvetica.

Testing… the problem persists in Adobe Products (AI & PSD). The font preview show fine in SF6 including the option/shift key combinations. And the same combinations work and show just fine in Quark 9.5. All using the Adobe PS fonts.

Checking System Fonts -Zapf ITC TT from Apple, locked in System… the SF6 DOES NOT display preview for the combination key characters in SF6. And you can’t turn this font off.

Using new iMac 27, El Capitan, CS6, Fusion 6