Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

Duplicates in the database


#1

xxxxxxxxxxxxxxxxxxx


#2

Certainly it is possible for the same file to be added - either from different locations or from the same location but by using different paths. The Windows Desktop client has a build in search for duplicates (by filename only) though this can be simulated on the Mac via a custom AppleScript.

A common cause of dupes is lack of care when setting up Watched folders (or re-making them). If The watched folder is set using a different explicit path to that used for the existing records, the items will be seen as new and added as new records. Consider server named ‘duckman’ at 123.456.789.10. These paths are not considered the same by Portfolio:

//duckman/folder/file.ext
//123/456/789/10/folder/file.ext

By looking at the paths of duplicates you should be able to see how they are arising.

There is no “do not allow duplicates” feature, before you ask though it’s a commonly requested feature. In fairness, exactly what constitutes a duplicate is a quite elastic definition depending on the individual.


#3

I just recently had this problem while setting up portfolio. For us the fix ended up being simple (after much back and forth with the people at Extensis). We had the wrong server address in the catalog defaults page in the Server Admin site. You need the same location in the “Create AutoSync Folders for new catalogs…” as the (parent folder)location where you are copying your files to, if that makes sense.


#4

The phrasing of this post indicates there IS a script that will accomplish this on a Mac. HOWEVER, I have not been able to get my script to work (and it DID work, for MANY YEARS, in previous versions), though I’ve tried and tried. I’ve also read in at least one other thread in this forum that others can’t get the “Find Duplicates” script to work.

SO: What’s the story? Is there a “Find Duplicates” script that will work with PF 8.5? Where can I get it?

TIA,

Dan (who would gladly give heaps of praise and thanks to anyone who has gotten such a script to work and would share it)


#5

ISTR I had a script I wrote/tested with v10.0.0 on OS 10.6.8, though I can’t find just this second. I don’t have v8.5 running locally so can’t test anyway.

As this may be blind alley, perhaps PM me if you want to follow up.


#6

Could you please post this script here? Or send it to me at ewelch [at] gia.edu?

Script Debugger is itchin’ for a workout. Thanks!

Eric


#7

Sent.