Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

DFS Compatibility Using Mac Client


#1

Using Portfolio Server 11 running on Windows 2008 server. When I mount a network share on a Mac using DFS and add some files from that share it shows a yellow dot status. If I chose to view original in Finder it can’t find the colon separated path. I can mount the direct share and it works as expected and it also works with dfs on a Windows client… Is not Portfolio Server compatible with dfs when a Mac mounts the share? :question:


#2

Since no one from Extensis has replied I must assume the Mac client software is NOT compatible with DFS.


#3

How exactly are you mounting the share? How are you adding the files? What path do you see in the catalog against those records with the yellow dot?


#4

I’m mounting the share onto the mac desktop with DFS path “cifs://dfs namespace/the/path/to/share”.
I add files by clicking add button or drag and drop from the mounted share on Desktop. Both ways will immediately bring up a dialog box to “Locate Original”. It displays the location of the missing file as the full DFS path colon separated. I do notice that if I open a new Finder window and click on the DFS namespace share I can’t get to the folder / files I want. I can click on the mounted share in Finder to access files. Not sure if this is how the Mac handles it or something is not set correctly. Perhaps this is the problem. If I were to open a file from the share from PhotoShop using AppleScript it works using…
tell application "Adobe Photoshop CS5.1"
open file "DigitalAssets:TestSync:28448-v20.tif"
end tell

It will not work if I change the line to…
open file “DFSnameSpace:files:art:DigitalAssets:TestSync:28448-v20.tif”


#5

Thanks for the answers. I think ‘cifs://dfs namespace/’ would be a feature request and is not currently supported. Certainly it sounds like it doesn’t work. I’ve only ever done installs where Macs are mounting fileshares via AFP of SMB, but I’ve done them where those fileshares are DFS Namespaces mounted via those protocols.

So I don’t think it’s the DFS so much as the way the share is being mounted. Have you tried mounting it as smb://dfsnamespace/?


#6

Actually DFS is not a protocol. You still use SMB or CIFS. Yes I’ve tried using smb and get the same results. It looks like Portfolio is using the full dfs path but not the way the mac wants it…