Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

Deactivating fonts


#1

Maybe I’m using SF4 incorrectly, but it’s my understanding that I can choose a font and temporarily activate it, use it in my project (e.g., Illustrator) and when I close the file, the font will be deactivated until I open it again.

Over time, I’ve noticed fonts are still active. I’ve ignored it for awhile, but my font list is growing and this is why I started using a font manager - so I can turn them on and off at will.

In order to deactivate, I had to go back and activate, then deactivate, then the font disappeared from the menu, as expected.

Am I doing something wrong?


#2

If you manually activate the fonts, then you need to manually deactivate them. If the fonts were automatically activated by our plug-ins they can be automatically deactivated on either document close, or application quit. But that’s a preference you can choose, so it could just be that your plug-in is not currently set to turn fonts off at all.


#3

Yes, I’m manually activating them, but it’s supposed to be temporary. So what is “temporarily activate fonts” doing then? I guess I’m confused with the various functions of Suitcase Fusion and the plugins and how they work together.

Here’s my workflow:
In Suitcase Fusion 4, I choose a font I want to use and choose “temporarily activate fonts”. Then, in my application, I use the font. I’ve got the Auto-Activation Preferences turned on to enable the fonts and to close when I quit.

I expect the fonts I’ve temporarily activated to now be unavailable in other apps, then available again when I open the file later.

How does it work with Microsoft apps? Maybe that’s what’s causing the problem?


#4

Auto-activation via the plug-ins and manual activation are two separate things. The plug-in will only turn off fonts that it turned on itself. It turns on fonts when you open a document that needs them, as it checks the document for what fonts are needed and then turns them on automatically. So it can cover the second part of your workflow where you’ve used a font, saved a document and go to open it again.

But the initial activation for the document editing is something you’re doing manually, and so those fonts are not turned on by the plug-in, and so then they won’t be turned off automatically by it either. ‘Temporary’ activation of fonts refers to the fact that they stay active until you restart the machine. After a restart they will not be turned on, whereas if you use the ‘permanent’ button they will stay on even after a restart.

So if you manually turn some fonts on and use them in a document, but don’t want them available after you’re finished, you need to manually turn them off after.


#5

Okay, I think I get it, so it’s not the auto-activation that’s not working (well actually, I’m having a separate issue with that as mentioned in another thread). But the issue is that when I restart my PC, the fonts I’ve temporarily activated are not being deactivated.

So how can I fix that?

Thank you for your patience.