Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

CS 2015 - Photoshop - Extensis panel not working after latest release/ update


#1

Yet again, after updating to yet another new version of Adobe Creative suite (2015.5.0), I get the error “This panel was unable to connect to Suitcase Fusion” in Photoshop. This is the panel that is supposed to show Google fonts.

I get this problem EVERY time Adobe updates to a new release of Creative Suite and Extensis then play catch up to fix it. The Extensis Panel has a problem yet again which I have to find out the hard way. This has happened to me over at least the past four times I’ve updated Creative Suite, wasting tens of hours and money.

I’m waiting to be told by Extensis something along the lines of the following YET AGAIN:

"Suitcase Fusion 6 is an older version we dont support the plugins for anymore, update to 7"
After I pay yet more money for a product that I might have only had for a year, and update to 7 and it still doesnt fix it "We’re aware of the problem, which is because Adobe have done ABC, our developers are working on a fix, it’ll be out soon. We couldnt prevent this … etc"
Several weeks and mutiple people asking when its going to be fixed, later, we’ll get told “almost ready …”.
Weeks pass by "yes, almost ready. Now in testing"
6 weeks from start of fault "OK, ready, can you download the fix?"
Some will still have problems but some it’ll work for until its tweaked after a week, yet again.

Extensis, this happens every time, every time I upgrade I wait more weeks for a fix!

Every time I get told lessons will be learnt but its Adobe’s fault. Pay up and wait!

Why such poor service and solutions?

Please let me know when this will be fixed?

Dave


#2

I’ve re-installed both Photoshop and Suitcase Fusion 6 and still not working.
Just checked the Plug-in manager and it seems that the new update to Photoshop and illustrator isnt recognised as being installed by the Plugin manager so isnt showing in the list to Enable/ Disable it. Either that or its not set up to look for it because it’s not supported. I assume this is why the panel isnt working or at least a part of the problem.
When’s this going to be updated/ fixed please?
Dave


#3

Compatibility for the latest Adobe CC applications is available in Suitcase Fusion 7 (version 18.1).
Extensis doesn’t have any plan to update Suitcase Fusion 6 at this time.

See more info here:


#4

it’s nice to not do update on a version that barely 2 years old. I have 2 computers and 1 mac, I’ll have to go to the checkout so. CS really great !!!