Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

Crashes QuarkXPress 2015


#1

If the Fusion update 17.3 is installed, quitting QXP causes crash report.


#2

UPDATE
@gt1948,

This is an issue Extensis is committed to fix it as soon as possible.
The work has been queued up but I can’t provide a fix date until we determine the root cause. We will work directly with Quark to resolve the problem as necessary.
The Extensis plugin team is finishing up another project over the next couple weeks and will get to this plugin fix right after.

I will update this forums post when I have something to share. Sorry for the delay.

Cheers,
Chris


#3

Following on from the issue of Quark crashing when using Suitcase Fusion 6 in El Capitan, I was told be various technicians at Extensis that they were looking into this weeks ago and kept being promised that an update to fix this would come next week, that was over a month ago and still nothing! As a short term fix the guys at Quark have suggested binning the ExtensisFontManagement XTension which does stop Quark crashing when using Suitcase Fusion, however this is far from ideal as obviously fonts then need to be manually activated! Matthias Guenther at Quark has been a great help but it really is the responsibility to put this right! On behalf of many loyal, patient customers can you please look at fixing this ASAP! Thank You.


#4

@lesjohnson,

I apologize if Extensis misled you to when this issue would be fixed. It’s never our intention and we are not ignoring your plea.

As I noted in my previous post, the fix is queued up as our next priority as soon as the font team completes their current project (currently targeted for end of Nov).

Of course it’s never our desire for you to remove our plugin but if you are running the latest QXP 2015 v11.2 update on El Capitan it may be your only option temporarily.

I will provide the target date for release as soon as I have more info to share.
If you need to test a build as soon as one is available I will post the beta link here.

We are sorry for the inconvenience this has caused. Extensis just wasn’t prepared for a Quark El Capitan update that would make our plugin incompatible. We need to do a better job of communicating with Quark prior to their public releases.
I am also in contact with Matthias regularly (I agree he is great!) and will work with him to improve our lines of communication going forward.

Cheers,
Chris


#5

“Misled”?

Indeed. After devoting countless hours with Extensis and Quark tech support, forums and on the phone regarding the incompatibility of SF6 with Quark 2015 under El Capitan, fact is after two months nothing has been done to fix this.

I have used this product since it was called Font Reserve many years ago. As a professional art director for several decades, I can appreciate the amount of effort it takes to make software compatible. I can forgive Extensis – to a degree – for their lack of resources, and consequently their low priority to fix this.

But what I find unconscionable is Extensis management continuing to list SF6 as compatible with Quark 2015 and El Capitan on their website. And continuing to email me offers for discounts on a product that I already bought, but that doesn’t work properly.

So in addition to being untrustworthy with their over-promising and under-delivering, I have to say that Extensis has a much bigger compatibility problem - with the truth. I mean, listing SF6 as compatible while continuing to heavily market it that way makes Extensis, by definition, liars.

Fact that Extensis management does not see the permanent damage they have done to their reputation, and customer relationship is mind-boggling.

Okay, I’m done griping.

Pass this along: It is Nov 30th as I write this. If a solution is not forthcoming shortly, my next investment of time to address this font management fiasco will be to erase Extensis Font Fusion 6 from my system and move on.


#6

Very well said djt… it’s months now and still no solution. The lights are quickly going out on 2015 and Apple will soon release 10.11.2 which might cause it’s own new issues… let’s just hope someone in Extensis actually care about the loyal professionals that use their product/products every day and get this fixed as a priority.

Regards,
Anthony


#7

Hello all,

This will be my last post in this forum until a fix is available (since mud has begun to sling).

Extensis appreciates your loyalty and sincerely apologizes for the inconvenience the delay has caused. We realize waiting is frustrating but your accusations are not accurate.

Let me clarify the facts:
Suitcase Fusion 6 is compatible and continues to work with Mac OS X 10.11.

Additionally, Extensis delivered support for QuarkXPress 2015 (v11.0) in version 17.2 on August 9, 2015 prior to the El Capitan release. This also included support for Adobe CC2015 applications and Windows 10 compatibility.

On October 8, 2015, Extensis released its El Capitan support for Suitcase Fusion 6 version 17.3 which was validated against earlier versions of QXP 2015 (versions 11.0 and 11.1).

The current issues you are experiencing were introduced afterwards in the latest release of QXP 2015 (version 11.2).

As I’ve mentioned before we will fix these issues and provide a free patch to QuarkXPress 2015 11.2 users as soon as it’s available. It is my personal goal to work more closely with the QuarkXpress team to ensure we don’t have future lapses in compatibility.

If you have any other questions or concerns please feel free to email me directly at: cmeyer@extensis.com

Thanks,
Chris


#8

“The current issues you are experiencing were introduced afterwards in the latest release of QXP 2015 (version 11.2).”

Excuse me but that is just not true.

I have not been able to open legacy Quark documents with SF6 in El Capitan – whether Quark 10 or Quark 2015 earlier or later versions – without Postcript fonts not rendering.

In addition, under El Capitan, even simple SF6 font previewing navigation within SF6 has a very long lag-time. In other words, it is slow and has a long delay when searching for fonts.

SF6 was and remains broken. And it has nothing to do with later updates to El Capitan or Quark.


#9

Hello David,

This forums post specifically relates to a crashing issue in QXP2015 (v11.2) that was reported on the day Quark released their update. I have scoured our support database and see your reports on 10/1 (case # 5089451) and then again on 10/19 (case # 5090206) about this very same issue. I’d like to keep us focused on this crasher so others can come to the post for periodic updates.

Unfortunately I wasn’t able to find any reports related to your other concerns listed in your last post.
Did you report these to our support team already? If so, do you recall who you talked with?

I am very interested in exploring any issues you have and sincerely working together for a resolution. I will have an engineer resource to handle the Quark plugin issue very soon and can investigate other problems you are facing.

Can you share details with my support team about the legacy Quark files and postscript fonts not rendering issues? Also I’d like to know more about the font preview navigation lag issues. If we can reproduce the issues in-house I’ll be able to address them for you. I currently do not have any reproducible issues in El Capitan so any information you can provide would be appreciated.

I realize your time is extremely valuable so I don’t take this inconvenience to you lightly.

As always you can email me directly if you have concerns or questions.

Regards,
Chris
cmeyer@extensis.com


#10

“Unfortunately I wasn’t able to find any reports related to your other concerns listed in your last post.
Did you report these to our support team already? If so, do you recall who you talked with?”

HERE IS A COPY & PASTE FROM ONE OF MY EMAILS TO EXTENSIS TECH SUPPORT, DATED OCT 15th:

Dear Extensis tech support,
I just updated from Quark 10 to Quark 2015. This included their recent update patch to be compatible with El Capitan.

I have been a QuarkXpress owner since 1989 and have used all versions thru Quark 10. On Oct 14, 2015 I purchased and installed Quark 2015 version 11.2.0 (compatible with El Capitan OSX 10.11) on my Mac Pro (late 2013).

Just prior to this, I had updated my Extensis Suitcase Fusion 6 to version 17.3.0, which is also compatible with El Capitan.

THE PROBLEM:
When I open my legacy Quark documents text boxes are empty. The font is “On” in Suitcase Fusion 6, and the Quark Utilities “Usage” shows that the font is associated okay as well. In addition, the document preview pane in Finder shows the layout and type look perfectly okay. But when the file is actually opened – the type box is empty in each document. Note: the layout is very simple, one 11x17 edge to edge photo with one text box headline over it.

STEPS I HAVE TAKEN:
I called Extensis tech support and was told that this is “a known problem” with both Quark and Extensis, but that they said they have no idea who or when this is going to be fixed.

They suggested a work-around:

  1. Uncheck and disable the ‘Auto-activation’ plug-in with the Suitcase Fusion 6 ‘Plug-ins Manager’.
  2. Manually ‘turn on’ the font in Suitcase Fusion 6.
  3. Drag and install the font file I want to use into the OS X Library Font folder.
  4. Reboot Quark.

I only tried this once, and it worked.

IMPORTANT:
I have thousands of fonts. If I can’t use my Suitcase Fusion font management app, and have to manually copy every font each time I use it to the Mac library, it makes using Quark 2015 impossible. So my office is essentially shut-down from using Quark until this is fixed.

AND LATER THAT SAME DAY - EMAIL FOLLOWUP:

Dear Extensis tech support,
This is an addendum to my last email.

Below please find a copy & paste of what Quark support just emailed me regarding the “known incompatibility” between Quark 2015 and Suitcase Fusion 6. Any update you can give me to this situation would be greatly appreciated.

Thank you.

David Thall

COPY & PASTE OF QUARK RESPONSE:

Dear David,
My name is Rahul Sharma, and I will assist you with this ticket, David we understands the situation you are in where the work becomes tedious but we would like to update you that suitcase fusion is a third party Extension therefore we cannot comment on the situation, we just need to wait until suitcase deploy a new patch for the compatibility issues.

Regards

Sincerely,

Rahul Sharma

Quark Support Team


#11

The name from the subsequent interaction at Extensis tech support was Ken Beck.

HERE IS A COPY & PASTE FROM MY EMAIL RESPONSE TO HIS INSTRUCTIONS, DATED OCT 18th:

Dear Ken Beck,

I have run the Extensis Diagnostic Terminal script you sent me and sent the results to you via FTP as per the instructions, along with the following information I think you will find helpful.

To help address the SF6 and Quark 2015 incompatibility issues, in addition to what you requested here is a detailed description of the problems, the temp work-around solutions that work to a degree, my Mac system setup – plus the answers to the your first email questions.

ANSWERS TO YOUR QUESTIONS:

  1. The problem is with a Postscript font (sent via FTP with all related files) so I don’t know. Quark is loading most fonts (when it’s not crashing), currently just not all of them.
  2. All Fonts are located in the ‘Vault’. (The problem font only works when dragged in to the Library though.)
    Vault Location:
    /Users/davidthall/Library/Extensis/Suitcase Fusion/Suitcase Fusion.fontvault
  3. Diagnostic script info was sent via FTP.

THE PROBLEM(S):
Quark 2015 and Suitcase Fusion 6 with their respective latest OS X upgrades – are compatible with OSX El Capitan to a degree – but not with each other in El Capitan.

SYMPTOMS:
Quark crashes.
Some type does not appear in Quark text boxes.
(Note: the type appears in the Finder file layout preview pane, and is listed as ‘okay’ in Quark’s ‘Usage’ utility – just not in the open file)

THE WORK-AROUND (TEMP) SOLUTION

  1. Disable the SF6 auto-activation Quark plug-in in the SF6 Plugins Manager. (Note: SF6 app remains ‘Active’.)
    Result: Quark stops crashing for a while and functioned smoothly - without the auto-activation.
  2. Manually drag and install the non-rendering font into the (top level) Library folder. Reboot Quark.
    Result: The typeface now appears normal in the Quark layout.

Note: Most fonts appear okay, so the ‘invisible’ font is not a universal problem. The font made ‘invisible’ by SF6 is a PS font.

ATTACHED FILES:

  1. The Quark doc and font (as you requested)
  2. Screen shot of my SF6 open window highlighting the font that SF6 is preventing from rendering in Quark 2015 in El Capitan. (as you requested)
  3. Screen shot of the open Quark file and empty text box - BEFORE the #2 workaround.
  4. A screen shot of the Finder preview pane of the Quark file – showing that the font appears okay in the Finder view - before the #2 workaround.
  5. A screen shot of the Quark file preview pane – showing that the font appears okay in the Finder - before the #2 workaround.
  6. A PDF showing the ‘BEFORE’ work-around described above above #2 of the Quark doc.
  7. A PDF showing the ‘AFTER’ work-around described above #2 of the Quark doc.

My System Setup:
OSX El Capitan v10.11
Quark 2015 v11.2
Suitcase Fusion v17.3
MacPro 6-core (late 2013) 64 GB RAM 1 TB SSD.

Separately, I reset the PRAM, the SMC and rebuilt the OS directory with DiskWarrior – though it reported no problems, and had no effect on the aforementioned SF6 incompatibilities.

Please Note:
When I first called Extensis tech support I was told that Extensis and Quark know of this compatibility issue, and suggested turning off auto-activation. However, Quark tech support believes all these issues are Extensis related and don’t have any suggestions except to disable Suitcase Fusion 6.

I hope this information is useful. I look forward to your solution.

Thank you.

David Thall
Case: 5090206

KEN BECK’S RESPONSE, DATED OCT 19TH:

hello david:
thanks for the files and additional information:
i will pass these on to our development team and keep you posted.
cheers,

Ken Beck
Support Technician
Extensis


#12

AND KEN BECK’S LATER RESPONSE, DATED OCT 22nd:

Hello David:

Thanks for the files.

  1. I am able to open your quark file “adlai.qxp” on osx 10.11 with SF6 v17.3.1 and have the correct “oldstyle” Postscript font load and display as long as the font is located in the SF6 font vault and the vault is located in your home folder (default settings).
    OSX 10.11 has some new security protocols and if the font is loaded in SF6 “in place” from anywhere outside your home directory (say the root of your hard drive for example), the font will load correctly for a split second and then disappear.

  2. We are aware of quark 2015 hanging/crashing on close/quit when our auto-activation plugin is installed. The current workaround is to remove our plugin.

hope that helps,

Ken Beck
Technical Support

NOTE: There’s more as I responded, etc, but I will spare you. I finally gave up as there was no new information that was useful.

Best,

d.


#13

Thanks David for the additional details.
I talked with Ken and I am hopefully up to speed now.
I also briefed my Quark plugin developer about the specific symptoms and asked him to test the use scenario you reported with the Postscript fonts supplied. He is confident the problem lies in the same code as the crasher but will confirm once he works on it.
I will reach out as soon as I can to provide you with a plugin to test.


#14

Include me and my production team on the list of people who need SF6 to work with Quark 2015.


#15

UPDATE
No problem adoughty, we will make an updated XT available as soon as we can. Keep watching here for further updates.

Our R&D team continues to work with Quark but we’re not making the traction we’d hoped for. We still don’t have a root cause for the crash.
We had decided (before the holidays) to start rewriting the QXP2015 XT from scratch in the event we were unable to patch our current one. That seems to be the best option right now.

I will provide another update next week as our work progresses.

Cheers,
Chris


#16

Hello all,

Quick update -
We are nearing the completion of our plugin addressing the QXP 2015 crash issue in El Capitan. Things are looking good and I should be able to hand off a version for you to test soon. After I receive feedback and my QA Engineers give the thumbs up I’ll get the official release out the door.

I’ll will update this post next week with the installer info.

Let me know if you have any questions.

cheers,
Chris


#17

Cheers for the update Chris… it’s been very frustrating not having a fully functional Suitcase Plugin for QuarkXpress 2015.

I/we look forward to getting our hands on the new fix as soon as you can release it.

Thanks again for the ongoing communication Chris. Much appreciated.

Regards,
Anthony


#18

Hello all,

I am posting the following beta version of our updated Quark XPress 2015 plugin (El Capitan) for your review.
IMPORTANT: This installer should only be installed by El Capitan users experiencing the QuarkXPress 2015 - Suitcase plugin crashing issue.

bin.extensis.com/SuitcaseFusion6-M-17-3-2-P1.zip

The new plugin has been stable in our tests but keep in mind it hasn’t been fully release tested yet. So please use it with caution (meaning install it on your main deadline driven production system at your own risk!)

If you prefer not to test this prerelease, my plan is to take customer feedback this week while giving my QA Team more time to completely test it.
As long as nothing unexpectedly comes up we will “officially” launch it next week.

Please share your feedback here and keep it focused to the “crash on quit” issue status.
If you encounter unrelated issues, private message me so I can investigate the details.

Cheers,
Chris
(cmeyer@extensis.com)


#19

Beta version for El Capitan loaded this morning.

Quark now can be quitted without crashing (Qk 2015 v. 11.2.0.1).
All fonts loaded properly, both when Quark opened from Dock and from double-clicking a file to open Qk.
(Still get the message that fonts are missing when in fact they are not.)
Problem seems to have been solved.

Note: I am testing El Capitan on an external drive; this is connected to a MacBook running Yosemite.
Installing today’s beta version also changed the Fusion extension in the Quark on Yosemite. Checked this version; it crashed instantly, when activated from Dock or file. Removed Fusion xtension from this version and replaced it with backup copy of previous xtension.


#20

All,

The official installer for this fix can be found here:
bin.extensis.com/SuitcaseFusion6-M-17-3-2.zip

We will push in-application notifications starting tomorrow.

Please let me know if you encounter any issues when installing.

Cheers,
Chris