Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

Auto Activation issues - Adobe Photoshop CC 2017


#1

I am using version Version 18.2.2 on Mac os Sierra 10.12.4
Working with Adobe Photoshop CC 2017, fonts are not activating - they are also on occasion substituting for Myriad. This is causing me lots of issues. Any suggestions please?


#2

Thanks for your question. Suitcase Fusion has a couple of settings in Photoshop you may want to check first.

In Photoshop under the following menus please make sure that All Libraries is selected:

File>Automate>Extensis

This allows fonts from all Workgroups and Libraries to be activated at all times. Versus only activating fonts from within one Library of fonts.

You can also select the Preferences button and deselect/un-check the “Pick the Best Match when original is missing”. This will stop font substitution for the missing fonts.

If your need assistance with these settings or have additional questions, please contact our Support Team at the link below.

https://www.extensis.com/company/contact-us/


#3

No joy. Any other suggestions?

The fonts are fine, if I manually open before opening the document, all ok. I specifically purchased this software for auto activation though, as I work on many projects in one day, with many fonts.


#4

It is possible an incorrect version of the Extensis Activation plug-in is installed. Please try the following steps:

  • Close all Adobe applications
  • Locate and remove the previous versions of the Extensis plug-ins from the following location(s) on your computer:

Application/[Adobe Application Name]/Plug-ins/Extensions/ExtensisFont…

Once they have been successfully removed, open the Suitcase Fusion application and select the Suitcase Fusion drop-down menu in the upper left corner next to the Apple menu. Then select Manage Plug-ins. Select the Adobe versions of the plug-ins you would like installed and click Done. Now launch your Adobe application(s) and see if everything is working as intended.

If this does not resolve the issue, please contact Support: http://www.extensis.com/company/contact-us/. They are available Monday-Friday 8AM-4PM PST.


#5

Is there any other way to get support? That number isn’t available from where I am. My network won’t connect :unamused:


#6

If needing support outside the US, please us the following phone number:

Outside North America:
+44 (0) 1604-654-270

If you are unable to contact us using the information above, please use our contact form below and our Support Team will contact you:

https://secure.extensis.com/technical-support


#7

Did you find a solution to this? I have been experiencing this same issue as well. I believe I’ve narrowed it down to Google Fonts not activating.


#8

Not exactly. Fonts now auto activate if I open the document twice, not ideal, but is working in a way.

One thing that support suggested, which has improved the situation where fonts were being incorrectly replaced - is to reset the System Fonts, there should be no more that 705 or so in Suitcase.

You do this by, launching the Font Book app within your Applications folder then use the ‘Restore standard fonts’ menu option and restart.

May be worth a try. I’m not aware what Google fonts is, so not sure this is something that is causing the issue here.


#9

I tried Restoring standard fonts in font book but it didn’t alleviate the problem; the extensis plugin still doesn’t work, even if I activate fonts manually I still have to close Photoshop and reopen it in order for the fonts to show up. I used to have the same problem where I had to open documents twice, but now it doesn’t work at all.


#10

It’s been a couple of weeks since your posts, ryan_fpm3 & Chuk_Design. Are you still having this issue? I am. And I’ve tried everything you guys have tried.


#11

I am still having problems, the auto activation plugin for photoshop simply does not work.


#12

Not only does the auto-activation not work properly, Photoshop is not seeing all activated fonts. I can manually turn on a font and Photoshop still won’t see it (no matter how many times I restart). Sometimes Photoshop only sees one in a whole set of fonts (the regular weight, but not the bold, for example). It’s sooooooooooooooooo very frustrating when I’m dealing with projects that go back years.


#13

It’s possible that it is not reading the appropriate Library for font activation in the Photoshop plug-in. Try the following steps:

  • Open Photoshop
  • Select File/Automate/Extensis…
  • When the Suitcase Fusion Plug-in panel opens, switch it from All Libraries to Font Library (or vise-versa) and try again.


#14

I gave that a try and it still isn’t working for me. I even tried changing it to Google Fonts and opened a PSD that I only used those font in and it activated some fonts and not others. But if I switch it to “All Libraries” or “Font Library” nothing is activated. The auto-activate plugins work fine in Illustrator and InDesign, just not Photoshop.


#15

Can you send me the version of the Adobe application you are using, and the full name of the Extensis plug-in found here:

Application/[Adobe Application Name]/Plug-ins/Extensions/ExtensisFont…


#16

I’m using Photoshop 2017.1.1
Plugin: ExtensisFontManagementPSCC2017.plugin
OS: Sierra 10.12.5
Suitcase 18.2.4 (1517)


#17

Auto-activation depends on the Fontsense ID embedded in each document/project. If you are using fonts that are no longer present in your Suitcase application, or the Fontsense ID is not embedded in the project then auto-activation will not occur.

http://www.extensis.com/font-management/universal-type-server/font-sense/


#18

So you are saying that Photoshop 2017 is not embedding the Fontsense ID into my projects? But InDesign 2017, Illustrator 2017 and Quark 2016 are embedding it because the problem does not exist there. Are you saying this is a Photoshop issue and that I need to take it up with them? It’s not a problem with the plug-in?

FYI, when I open a Photoshop document, the fonts ARE auto activated in Suitcase, but they change to Myriad in Photoshop. Then, if I close the document and then reopen the document, the fonts show up in Photoshop – in most cases. Occasionally, I have to close and reopen Photoshop for the font to show up.


#19

We would like to see this issue in person. Please contact our Support Team using the link below: https://www.extensis.com/company/contact-us/


#20

So I contacted Extensis support as requested. They say it’s a Photoshop problem because Suitcase is auto activating the fonts, Photoshop is either not seeing them or is responsible for converting my fonts to Myriad. I talked to Adobe and they say it’s a problem with Extensis and that they don’t support third party software. So I’m back to where I started. Some fonts show up in Photoshop, some convert to Myriad. So very frustrating and dangerous!!!