Extensis Logo SUPPORT | FORUMS | KNOWLEDGE BASE

Adobe Creative Cloud (2015) Compatibility


#41

Last saturday I already send a mail to Extensis about the problems I encountered using the new SF. This was about the problems in Photoshop:

  1. With the plugin enabled Photoshop takes 1 minute and 50 seconds to launch and I get a message that hardware acceleration was disabled. Photoshop is slow…

  2. With the plugin disabled Photoshop takes exactly 7 seconds to launch and HW accelereation (gpu Geforce GTX 970) is enabled hence Photoshop is a lot faster.

In the meantime I tried some things. I manualy installed the PS CC 2014 plugin in the PS CC 2015 plugin folder and this works mostly as expected (auto font activation). A work around for me for now. Photoshop is fast.

In Indesign I have problems with larger files like a magazine. Everytime I change something, a suitcase window pops up and disappears again. Very irritating. Also is the plugin slowing Indesign down a lot. Removing the plugin or disabling “Font Sense support” and “Pick the best match when original is missing” speeds things up a lot. This phenomen is not happening with small files like flyers or posters.

In Illustrator I experienced problems with a large DIN A3 infographics (about 100 MB) containing quite a lot of text. Illustrator crashed on this file with the SF plugin enabled. With the plugin disabled I could open the file in no time and Illustrator is responsive and fast as to be expected.

I get the impression that this version of SF for WIndows is released under too much pressure. It is not working well at all.

My system is fresh installed Windows 10 with Adobe CC 2015.
Core i7 5820 with 64 GB memory
Geforce GTX 970 graphics card.


#42

Hey Chris!
giant has exactly same problems than mine!

Oh gosh … I just ordered a new graphic card thinking that that was the problem (mine was an old GeForce GT230)
I hope I am not going to have the same issue :-S

@giant: it happens to you also that with big files PS saves them with a strange prefix like ._##_nameoffile?

On my other pc, a Samsung laptop, with an Intel HD Graphics 4000 it works like a charme.
Now I have a doubt: something to do with Nvidia cards?
I have also on the laptop a GT630M: I am going to force PS to use it instead of the Intel and see what happens.
I will post the results here.

update

Bad news :smiley:
Forcing PS to use the Nvidia card I have exactly the same problems!
Disabling ‘Use Graphic Processor To Accelerate Computation’ it works like it should do.

Again, using the Intel HD Graphics 4000 with GPU enabled it works with ZERO problems on the same machine.

Maybe it could be of help to search for the bug …

Thanks!

  • Mariella

#43

Hello all,

I am going to take all of your reports and convert them into separate support tickets so we can track these issues. Please expect an email from myself or one of our technicians on how we plan to proceed.

@ Mariella - We have had performance issues in the past related to Windows nvidia graphics cards so we will definitely look into that area. Note: I’m not saying it’s definitely the reason at this point but it is an area of concern for our team.
If needed we will reach out to nVidia and work with their engineers if we can reproduce the issues on our internal equipment.
Stay tuned for more details about that…

PS. I will also update this thread for everyone as soon as we learn more about the issues.

Chris


#44

Ok Chris,thanks!
When I install my new Nvidia (sob … :slightly_smiling:) I will make another test and let you know here!

  • M

#45

Thank you and my apologies for the poor experience.
Hopefully we’ll have this issue addressed quickly.


#46

FYI, I’m running a Radeon R9 290X and I’m not experiencing any of these problems (as far as I can tell).


#47

Thank you all for your feedback here.

From your excellent detective work and our own preliminary testing signs are pointing to an incompatibility between the Suitcase plugins and nVIDIA accelerator software/hardware.

We are in the process of refocusing our Suitcase testing lab to Windows machines with nVIDIA (GeForce) cards.
Unfortunately our testing before the release didn’t have these specific series of video cards installed.

In the unlikely event we are unable to reproduce the issue internally we may enlist some of you to test a debug plugins build that would provide us a clear stack trace of the failure.

Stay tuned…


#48

@ fcpdu
@ veradg:

Can the both of you verify you are also running hardware with an NVIDIA (GeForce) card?
If so please list the model as well.

Thanks
Chris


#49

I can confirm the Photoshop issues. Win 7 x64, i7-3930K, 24GB DDR3, dual nVidia 650Ti. One spin on this - the whole computer becomes unusable while Photoshop is loading. I’ve disabled the Photoshop plugin and all the problems go away.


#50

Glad to have helped out!
I am available for testing if you need :wink:


#51

yes i work with a geforce 660 gtx and i have the same problems like “giant”.


#52

Chris:
Windows 10 Pro 64-bit.
Intel Core I7-2670QM CPU @ 2.20GHz, 8,0GB RAM, Intel HD Graphics 3000, Nvidia GeForce GT540M

photoshop CC 2015


#53

after several tests and after also having found me a huge slowdown when launching Photoshop CC 2015 with suitcase 6, I decided to disable the plugin in suitcase. Having photoshop CC 2014, I was surprised to found a quick loading photoshop 2015 cc My conclusion is the following: this is the latest version of suitcase 6 plugin that is struggling to load (more than minute to access photoshop cc 2015).

Sorry for my english, i m french :wink:


#54

Thank you all again for the continued feedback. We should have our nVIDIA GeForce card in house by Friday (tomorrow) and expect to start testing more thoroughly by Monday.
We are optimistic we’ll figure out the root cause next week and determine how to address the issue so you can start using the plugins properly.
Stay tuned…

cheers,
Chris


#55

Today I recieved a mail from Extensis. I provided them with the requested information, logs and screenshots. I really hope this will help. SF is a real timesaver for me in my daily work.

As for Photoshop, I tried the SF plugin with GPU acceleration disabled. But it took Photoshop even longer to launch. More than 2 minutes. Without the plugin it takes about 6 seconds. Cancelling Photoshop from the long launch, I got a message when launching it again.

I’m afraid that this can take a while… I’m convinced that Extensis do their best but I already updated to CC 2015. There’s no way back, CC 2015 InDesign files can not be opened in previous versions…:frowning:

Cheers, Jan


#56

'morning everyone.

Tested today with GeForce GT740

Same problems!

  • Mariella

#57

Hi! I know you are all busy with the nvidia problem and all (I too have a nvidia card and hoping for a fix for that) but I have a different problem as well: After updating to cc2015 (and still after updating SF from the link in this thread) when opening Illustartor or PS i get this error message:

“The Univesal Type Client application that is currently running is incopatible with the Universal plug-in.
Please make sure you are running the latest version of Universal Type Client…”

What is this UTC? Has it got something to do with Universal Type server? I have never used Universal type server as far as I know…

Other issues: 1. The plug-in panel in Illustartor and PS is empty and will not load, even after updating SF.

                          2. I still need to use the run as administrator-"hack" to open SF.

About Nvidia: I have a Nvidia GT540M. (8gb RAM And Win10) I have not noticed any difference in loadingspeed after updating CC or Win. That could be because my plug-in panel won´t load, or because Illustrator and PS has always been very slow to load (around a minute), and the SF-plug-in was always so slow to load that I would only use it if it was really necessary. The plugin could even cause app crash.

I know you guys are working hard now and I hope find some fixes soon. SF is a great app and as a web designer I can not live without it. Too bad it has speed issues and now compability issues as well. It would really make a difference if you could fix this.


#58

@giant, thanks for providing additional info. As much as we hate suggesting this - temporarily disabling our plugins is clearly the only option for the time being. I expect we’ll understand the root cause very soon and provide an update as quickly as possible. I will share an estimated fix date soon.

@grossmisconduct - To explain the confusing message, Suitcase Fusion and Universal Type Client (UTC) share the same messages and once invoked the appropriate version message is supposed to display. Not sure why you are seeing the UTC one but the problem is the same - there is a mismatch between the Suitcase client application and the plugin versions.
Did you perhaps manually install the the CC2014 plugins in your PS or ILLCC2015 plug-ins folder before upgrading to the latest Suitcase Fusion 6 (v17.2)?
If not, please provide the version of your Suitcase application - go to Help menu > About Suitcase Fusion…
Please provide your plugin version for Illustrator and Photoshop - go to the Tools menu > Manage Plug-ins…
It’s likely some clean up and re-install will get you past this issue.

Let me know.
Chris


#59

Hello all,

Our latest update:
The problem has been reproduced internally and we’ve determined the root cause.
Re: We’ve isolated an issue between the geforce’s installed software and our plugin’s missing font validator. It affects all plugins although Photoshop and InDesign clearly exhibit the worst behavior.

We are working on a fix and will post it as soon as possible (estimated time: within a week). I will update this post with the installers as soon as possible.

Let me know if you have any questions or concerns.

Cheers,
Chris


#60

thanks Chris!