Adding fonts issue


Suitcase Fusion had worked fine when suddenly has stopped to adding fonts. I removed all fonts, and couldn’t add them back again. I have Windows 10. Few times I installed/uninstalled SF, but there’s no use. Every time I tried to remove SF, I have some leftovers in registry. Even manually I couldn’t remove everything. Also, I had deleted Extensis folder in AppData, ProgramData and of course Program Files, and still has some kind of leftovers in registry I suppose.

I’d be very thankful if someone detect the problem.



Hi again!
I installed SF on fresh Win10 Enterprise x64, on other computer, and still there is same problem. I tried to run in compatibility mode, As Admin,… add these parameters to the FMCore, and other executable files. Maybe it was caused by some Win update… As I write before, it had been worked and suddenly stopped. I’m desperate :frowning:



I have the exact same problem. Started for me when I updated to Windows 10. I’ve tried uninstalling etc.

When I try dragging a font it has a stop sign (circle with line across it) and won’t drop anywhere in Suitcase.
When i try File - Add it lets me select it but once I hit add nothing happens.
I can move fonts no problem within the program, just can’t add new ones.
Even tried a new vault in different location and no difference.

Tried everything I can think of and absolutely nothing comes up on google about it.

At this stage I’m looking for alternative font managers.


I still haven’t found solution for this issue :frowning:
Does anyone?


Hi eraserhead,

Here is a KBA that might be of use to you. Recent updates to Windows 10 have included the resetting of registry keys which can affect your use of Suitcase Fusion. There is another thread on the forums that discusses this further.

If you are continuing to experience this issue, please contact our Support team using the link below: